Bug 189233 - enchant rpm does not build due to compile error
enchant rpm does not build due to compile error
Status: CLOSED DUPLICATE of bug 313231
Product: Fedora
Classification: Fedora
Component: hspell (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-04-18 10:43 EDT by Prarit Bhargava
Modified: 2008-02-14 07:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 14:31:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-04-18 10:43:06 EDT
Description of problem:

enchant rpm does not build due to compile error.

Version-Release number of selected component (if applicable):

enchant-1.2.5-2.fc6.src.rpm

How reproducible: 100%


Steps to Reproduce:
1. rpmbuild --rebuild source.rpm or rpmbuild -bb spec.file

Actual results: build fails with

gcc -shared  .libs/hspell_provider.o  -Wl,--rpath
-Wl,/usr/src/redhat/BUILD/enchant-1.2.2/src/.libs -lgmodule-2.0 -ldl -lglib-2.0
-lhspell -lz ../../src/.libs/libenchant.so  -Wl,--export-dynamic -Wl,-soname
-Wl,libenchant_hspell.so -o .libs/libenchant_hspell.so
/usr/bin/ld:
/usr/lib/gcc/ia64-redhat-linux/4.1.0/../../../libhspell.a(libhspell.o): @gprel
relocation against dynamic symbol hspell_debug
/usr/bin/ld:
/usr/lib/gcc/ia64-redhat-linux/4.1.0/../../../libhspell.a(libhspell.o): @gprel
relocation against dynamic symbol hspell_debug
/usr/bin/ld:
/usr/lib/gcc/ia64-redhat-linux/4.1.0/../../../libhspell.a(libhspell.o): @gprel
relocation against dynamic symbol hspell_debug
/usr/bin/ld:
/usr/lib/gcc/ia64-redhat-linux/4.1.0/../../../libhspell.a(libhspell.o): @gprel
relocation against dynamic symbol hspell_debug
/usr/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld returned 1 exit status
make[2]: *** [libenchant_hspell.la] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/enchant-1.2.2/src/hspell'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/enchant-1.2.2/src'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.59881 (%build)

Expected results: build should succeed.


Additional info: I'm not sure if this really is an enchant issue, or if the
fact that the hspell-devel rpm does not have a libhspell.so ...

[root@altix2 SRPMS]# locate libhspell.a
/usr/lib/libhspell.a
[root@altix2 SRPMS]# rpm -qf /usr/lib/libhspell.a 
hspell-devel-0.9-7
[root@altix2 SRPMS]# rpm -ql hspecll-devel
package hspecll-devel is not installed
[root@altix2 SRPMS]# rpm -ql hspell-devel
/usr/include/hspell.h
/usr/include/linginfo.h
/usr/lib/libhspell.a
/usr/share/man/man3/hspell.3.gz
Comment 1 Marc Maurer 2006-10-12 14:31:47 EDT
Works for me (just committed enchant 1.3.0). Maybe the more recent hspell has it
fixed. At least it doesn't seem to be an enchant issue in any way I could think of.
Comment 2 Caolan McNamara 2008-02-14 07:28:24 EST
hspell is the offender

*** This bug has been marked as a duplicate of 313231 ***

Note You need to log in before you can comment on or make changes to this bug.