Bug 18926 - kernel 2..4.0-src is badly packaged.
Summary: kernel 2..4.0-src is badly packaged.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-12 01:40 UTC by Spider
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-12 01:40:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Spider 2000-10-12 01:40:53 UTC
before any configuration would be compiled, we had to do make distclean and
reconfigure, or it would hang somewhere around:
 In file included from ksyms.c:18:
 /usr/src/linux-2.4/include/linux/kernel_stat.h: In function `kstat_irqs':
 /usr/src/linux-2.4/include/linux/kernel_stat.h:98: `smp_num_cpus'
undeclared (first use in this function)

also is there some inconsistence between make menuconfig and make config?
I'm wondering most around the cpu specific changes arch/i386/config.in
since they weren't included in first attempted config (menuconfig) but with
make config they were...

Comment 1 Bill Nottingham 2000-11-04 07:40:15 UTC
You need to run 'make mrproper' first.

Comment 2 Rex Henderson 2000-12-04 17:37:02 UTC
Given the advice, this package is still badly broken. I still cannot get the 
kernel to compile. But it is not all RedHat's fault. I downloaded the kernel 
source from www.kernel.org and had similar problems dependant on the settings I 
chose (like if I chose a cpu model above i586, I got the same errors).
But the RedHat release takes this a step farther. I cannot get ANY  
configuration to compile...



Note You need to log in before you can comment on or make changes to this bug.