Bug 189262 - grabbing stage2.img from boot cd bypasses tree timestamp check
Summary: grabbing stage2.img from boot cd bypasses tree timestamp check
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Lehman
QA Contact:
URL:
Whiteboard:
Keywords:
: 189258 (view as bug list)
Depends On:
Blocks: 176344
TreeView+ depends on / blocked
 
Reported: 2006-04-18 17:10 UTC by David Lehman
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0215
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 17:20:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0215 normal SHIPPED_LIVE anaconda, and rhpl bug fix update 2007-05-01 17:16:50 UTC

Description David Lehman 2006-04-18 17:10:58 UTC
Description of problem:
The new code in anaconda-10 that grabs stage2.img from cdrom if possible
prevents the timestamp checking code from being effective at preventing install
media mismatches. If the boot media contains RedHat/base/stage2.img (like full
disc1), the user specifies askmethod, and the NFS/URL tree is not matched with
the booted installer, it will not be detected.

Version-Release number of selected component (if applicable):
anaconda-10.1.1.13-1

How reproducible:
Always

Steps to Reproduce:
1. boot from RHEL4 disc1 and askmethod
2. specify a RHEL3 NFS target tree
3. 
  
Actual results:
install will proceed with varying (probably not good) results

Expected results:
installer stops and tells user to match the boot/install media

Additional info:
This is a regression since this scenario would be prevented prior to the
addition of code to grab stage2 from cdrom when possible.

Comment 2 Chris Lumens 2006-05-11 19:26:08 UTC
*** Bug 189258 has been marked as a duplicate of this bug. ***

Comment 3 RHEL Product and Program Management 2006-08-18 16:14:46 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Peter Jones 2007-01-30 19:51:39 UTC
Should be fixed in anaconda-10.1.1.55-1 .

(It's wonderful irony that I'm telling you this ;)

Comment 10 Red Hat Bugzilla 2007-05-01 17:20:50 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0215.html



Note You need to log in before you can comment on or make changes to this bug.