Bug 189275 - beagle-0.2.4-1.fc5.1 includes two copies of the crawl-system script
beagle-0.2.4-1.fc5.1 includes two copies of the crawl-system script
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 14:39 EDT by Gordon Messmer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 12:18:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Messmer 2006-04-18 14:39:47 EDT
Description of problem:
beagle-0.2.4-1.fc5.1 includes two files in /etc/cron.daily:
/etc/cron.daily/beagle-crawl-system
/etc/cron.daily/beagle-crawl-system.cron

"beagle-crawl-system.cron" calls /usr/libexec/beagle-crawl-system, which is
exactly the same as the file in /etc/cron.daily of the same name.  As a result,
the system is being indexed twice, every morning.
Comment 1 Gordon Messmer 2006-04-18 14:42:52 EDT
It looks like this section of the spec, as well as "Source2" could simply be
removed:

# use anacron instead of cron, so beagle-crawl-system has 
# a reasonable chance to run
rm -rf $RPM_BUILD_ROOT/etc/cron.d
mkdir -p $RPM_BUILD_ROOT/etc/cron.daily
cp %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/beagle-crawl-system.cron
chmod +x $RPM_BUILD_ROOT/etc/cron.daily/beagle-crawl-system.cron
Comment 2 Alexander Larsson 2006-04-24 12:18:08 EDT
Should be ok in 0.2.5.

Note You need to log in before you can comment on or make changes to this bug.