Bug 1892833
| Summary: | Lots of sudo commands leads to errors | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 8 | Reporter: | Orion Poplawski <orion> |
| Component: | systemd | Assignee: | Michal Sekletar <msekleta> |
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Frantisek Sumsal <fsumsal> |
| Severity: | medium | Docs Contact: | |
| Priority: | medium | ||
| Version: | 8.3 | CC: | chorn, dtardon, msekleta, rmetrich, systemd-maint-list, tdoucet |
| Target Milestone: | rc | Keywords: | Triaged |
| Target Release: | 8.0 | Flags: | pm-rhel:
mirror+
|
| Hardware: | All | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2022-05-31 13:53:14 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Description
Orion Poplawski
2020-10-29 18:43:38 UTC
So I tried disabling the start limit, but still end up with lots of errors: Oct 30 09:28:03 localhost systemd[2094125]: Starting Exit the Session... Oct 30 09:28:03 localhost sudo[2094145]: root : TTY=unknown ; PWD=/opt/LansweeperAgent ; USER=root ; COMMAND=/usr/sbin/dmidecode Oct 30 09:28:03 localhost sudo[2094145]: pam_systemd(sudo:session): Failed to create session: Start job for unit user-0.slice failed with 'canceled' Oct 30 09:28:03 localhost sudo[2094145]: pam_unix(sudo:session): session opened for user root by (uid=0) Oct 30 09:28:03 localhost systemd[1]: Started Session c37 of user root. Oct 30 09:28:03 localhost sudo[2094145]: pam_unix(sudo:session): session closed for user root Oct 30 09:28:03 localhost systemd[1]: Starting User Manager for UID 0... Oct 30 09:28:03 localhost sudo[2094158]: root : TTY=unknown ; PWD=/opt/LansweeperAgent ; USER=root ; COMMAND=/usr/sbin/dmidecode -t 6 Oct 30 09:28:03 localhost systemd[1]: Started Session c38 of user root. Oct 30 09:28:03 localhost systemd[2094155]: pam_unix(systemd-user:session): session opened for user root by (uid=0) Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Reached target Timers. Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused Oct 30 09:28:03 localhost systemd[2094155]: Reached target Paths. Oct 30 09:28:03 localhost systemd[2094155]: Failed to connect to API bus: Connection refused This feels pretty heavy-weight for just running some sudo commands, especially by a daemon. This may be fixed in 8.3, at least I'm not seeing it on my one RHEL 8.3 VM. I'll know more once CentOS 8.3 is out and my other machines update. systemd-239-41.el8_3.x86_64 Things are definitely better with 8.3, but still can see errors like this: Dec 10 01:37:38 localhost sudo[84839]: pam_unix(sudo:session): session opened for user root by (uid=0) Dec 10 01:37:38 localhost sudo[84839]: pam_unix(sudo:session): session closed for user root Dec 10 01:37:38 localhost systemd[1]: session-c2.scope: Succeeded. Dec 10 01:37:38 localhost systemd[1]: Stopping User Manager for UID 0... Dec 10 01:37:38 localhost systemd[84842]: Stopped target Default. Dec 10 01:37:38 localhost systemd[84842]: Stopped target Basic System. Dec 10 01:37:38 localhost systemd[84842]: Stopped target Sockets. Dec 10 01:37:38 localhost systemd[84842]: dbus.socket: Succeeded. Dec 10 01:37:38 localhost systemd[84842]: Closed D-Bus User Message Bus Socket. Dec 10 01:37:38 localhost systemd[84842]: Stopped target Timers. Dec 10 01:37:38 localhost systemd[84842]: Stopped target Paths. Dec 10 01:37:38 localhost systemd[84842]: Reached target Shutdown. Dec 10 01:37:38 localhost systemd[84842]: Starting Exit the Session... Dec 10 01:37:38 localhost systemd[1]: user: Succeeded. Dec 10 01:37:38 localhost sudo[84859]: root : TTY=unknown ; PWD=/opt/LansweeperAgent ; USER=root ; COMMAND=/usr/sbin/dmidecode -t 0 Dec 10 01:37:38 localhost systemd[1]: Stopped User Manager for UID 0. Dec 10 01:37:38 localhost systemd[1]: Starting User Manager for UID 0... Dec 10 01:37:38 localhost sudo[84859]: pam_systemd(sudo:session): Failed to create session: Start job for unit user-0.slice failed with 'canceled' Dec 10 01:37:38 localhost sudo[84859]: pam_unix(sudo:session): session opened for user root by (uid=0) Dec 10 01:37:38 localhost systemd[1]: Started Session c3 of user root. Dec 10 01:37:38 localhost sudo[84859]: pam_unix(sudo:session): session closed for user root Dec 10 01:37:38 localhost systemd[84869]: pam_unix(systemd-user:session): session opened for user root by (uid=0) Dec 10 01:37:38 localhost systemd[1]: session-c3.scope: Succeeded. Dec 10 01:37:38 localhost sudo[84878]: root : TTY=unknown ; PWD=/opt/LansweeperAgent ; USER=root ; COMMAND=/usr/sbin/dmidecode -t 1 Dec 10 01:37:38 localhost systemd[1]: Started Session c4 of user root. Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Reached target Timers. Dec 10 01:37:38 localhost systemd[84869]: Failed to connect to API bus: Connection refused Dec 10 01:37:38 localhost systemd[84869]: Starting D-Bus User Message Bus Socket. Dec 10 01:37:38 localhost systemd[84869]: Reached target Paths. Dec 10 01:37:38 localhost systemd[84869]: Listening on D-Bus User Message Bus Socket. Dec 10 01:37:38 localhost systemd[84869]: Reached target Sockets. Dec 10 01:37:38 localhost systemd[84869]: Reached target Basic System. Dec 10 01:37:38 localhost systemd[1]: Started User Manager for UID 0. systemd-239-41.el8_3.x86_64 Hmm, looks like we can still run into the original errors as well: Dec 15 14:58:49 localhost systemd[1]: Started Session c78 of user root. Dec 15 14:58:49 localhost systemd[1]: user-runtime-dir: Start request repeated too quickly. Dec 15 14:58:49 localhost systemd[1]: user-runtime-dir: Failed with result 'start-limit-hit'. Dec 15 14:58:49 localhost systemd[1]: Failed to start /run/user/0 mount wrapper. Dec 15 14:58:49 localhost systemd[1]: Dependency failed for User Manager for UID0. Dec 15 14:58:49 localhost systemd[1]: user: Job user/start failed with result 'dependency'. Dec 15 14:58:49 localhost sudo[132510]: pam_systemd(sudo:session): Failed to create session: Start job for unit user failed with 'dependency' Dec 15 14:58:49 localhost sudo[132510]: pam_unix(sudo:session): session opened for user root by (uid=0) Dec 15 14:58:49 localhost sudo[132510]: pam_unix(sudo:session): session closed for user root Can you try with testing rpms from http://people.redhat.com/dtardon/systemd/bz1642460-backport-UserStopDelaySec=/ ? Customer seems to be hitting this issue in OpenStack in case 03051999. does this have any impact or can these be safely ignored? Thanks! (In reply to Tommy Doucet from comment #9) > Customer seems to be hitting this issue in OpenStack in case 03051999. does > this have any impact or can these be safely ignored? Thanks! This has been in this state for a while now. Any update on this? Can this issue be safely ignored? Thank you! I don't think I'm seeing any more errors with systemd-239-51.el8_5.3.x86_64 This bug seems to be fixed in 8.5 and above, so let's close this. If you encounter this issue on newer version feel free to reopen the bug. |