Bug 189305 - printer driver not detected
Summary: printer driver not detected
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: foomatic   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard: bzcl34nup
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-19 00:49 UTC by Matthias Clasen
Modified: 2008-08-02 23:40 UTC (History)
2 users (show)

Fixed In Version: F-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 17:16:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal output (91.11 KB, application/octet-stream)
2006-04-20 03:15 UTC, Matthias Clasen
no flags Details

Description Matthias Clasen 2006-04-19 00:49:58 UTC
When I log into this rawhide machine, eggcups pops up a dialog
asking for the printer driver.

a) It is irritating that it say the driver for "HP Deskjet 3740" was
not detected, even though there is an entry for "Deskjet 3740" under
"Hewlett-Packard".

Checking in hal-device-manager, the printer shows up with the fields
info.product "Deskjet 3740"
info.vendor "Hewlett-Packard"
and the same strings for usb_device


b) The dialog needs urgent HIG love

Comment 1 John (J5) Palmieri 2006-04-19 15:10:17 UTC
can you attach the full output of lshal.  Thanks.

Comment 2 Matthias Clasen 2006-04-20 03:15:56 UTC
Created attachment 128020 [details]
lshal output

Comment 3 John (J5) Palmieri 2006-04-20 22:03:59 UTC
HP has this problem where they don't know what to call themselves.  If you
notice in the lshal output usb.vendor = "Hewlett-Packard" but printer.vendor =
"HP".  We key off of printer.vendor because that is the IEEE string.  Foomatics
needs to be updated to reflect this.

Comment 4 Tim Waugh 2006-04-20 22:21:11 UTC
John: this is usually because there just isn't an IEEE 1284 Device ID for the
device concerned in the foomatic database, not because some string needs
tweaking.  Foomatic is completely consistent in the *user presentation* forms of
the manufacturer names.

It's only the IEEE 1284 Device ID MFR names that vary, and that is completely
hidden from the user.

Matthias: the dialog needs completely re-working for the new
system-config-printer.  No polishing should be done on the existing stuff until
we've all had a talk about how the new thing should work.

Comment 5 Bug Zapper 2008-04-03 17:12:02 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 6 Tim Waugh 2008-04-03 17:16:00 UTC
That dialog no longer exists.


Note You need to log in before you can comment on or make changes to this bug.