Bug 18931 - Kernel 2.2.16 included, but headers for 2.4.0
Summary: Kernel 2.2.16 included, but headers for 2.4.0
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-12 05:10 UTC by John William
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-12 05:10:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John William 2000-10-12 05:10:44 UTC
The standard install uses kernel 2.2.16, but kernel headers for 2.4.0. 
This makes it difficult (impossible?) to compile some modules since you're 
compiling for a 2.2.x kernel, but the distro includes 2.4.0 kernel header 
files.

One example is the differences between then 2.2.x and 2.4.0 version 
of /usr/include/linux/netdevice.h. The distro version of this file will 
not compile many network drivers because of changes to the net_device 
structure.

I suggest the proper fix is to provide a 2.2.x version of kernel-headers 
with the 2.2.x kernel.

Comment 1 Alan Cox 2000-10-14 18:04:00 UTC
The current setup is correct. - /usr/include/linux and /usr/include/asm are
supposed to match the C libraries and have been meant to for all glibc users.
Glibc 2.2 needs 2.4 kernel headers for the features it uses and exposes to
applications.

Kernel modules should use the headers with the kernel but cannot rely on those
being in /usr/include/linux.



Note You need to log in before you can comment on or make changes to this bug.