Bug 189311 - sunrpc.tcp_slot_table_entries=64 is not presistent over reboot in sysctl
sunrpc.tcp_slot_table_entries=64 is not presistent over reboot in sysctl
Status: CLOSED DUPLICATE of bug 189310
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2006-04-18 22:11 EDT by Sanjay Gulabani
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-30 03:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sanjay Gulabani 2006-04-18 22:11:08 EDT
Description of problem:
NFS sunrpc module allows one to specify sunrpc.tcp_slot_table_entries 
This parameter is set to default of 16 in sunrpc module AFAIK.
This parameter can be put in /etc/sysctl.conf. Putting a value of say 64 and 
rebooting the machine causes the value of this parameter as observed by 
sysctl -a | grep sunrpc to show up as 16.
When setting it up manually with sysctl -w sunrpc.. it works fine but if put in
sysctl.conf it doesn't.

Version-Release number of selected component (if applicable):

Redhat Enterprise Linux 4 update 3
How reproducible:
Description of the problem is sufficient to explain the reproduction

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

This problem was observed at highly escalated performance problem at Yahoo a 
NetApp customer that deploys their application on Redhat linux on Oracle 
database on opteron hardware.

We have observed that from the init script the sysctl is invoked only in 
S10network script. 
S18/S19 level rcp init script issues a modprobe sunrpc which probably load the 
sunrpc module. It is likely that S10network sets this value correctly but 
sunrpc module upon load up causes this value to be reset back to 16.

A simple workaround of adding /sbin/sysctl -p line in S25netfs has been 
provided to yahoo. But they would like a fix eventually from Red Hat.
Comment 1 Sanjay Gulabani 2006-04-18 22:13:36 EDT
Please mark this as duplicate of 189310. I submitted twice.. my bad.
Comment 2 Steve Dickson 2006-05-30 03:53:02 EDT

*** This bug has been marked as a duplicate of 189310 ***

Note You need to log in before you can comment on or make changes to this bug.