Bug 189318 - yum reliably triggers oom-killer
yum reliably triggers oom-killer
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 22:30 EDT by James G. Sack
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 23:50:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James G. Sack 2006-04-18 22:30:35 EDT
Description of problem:
Yum suddenly started triggering the oom-killer today.

Version-Release number of selected component (if applicable):
I tried sever versions on yum 
 from latest repo-yum as/of few days ago
 to yum-2.4.2-69.rhfc4.at.x86_64.rpm
 & yum-2.6.0-1.src.rpm from FC5 sources
I tried a couple of kernels (stock FC4, x86_64)
 2.6.16-1.2069_FC4 
 2.6.15-1.1833_FC4

How reproducible:
 Every time since just today. 

Steps to Reproduce:
1. yum info yum (actually seems independent of args)

  
Actual results:
2. after 5 seconds-or so, starts using swap
3. after few-more secs starts oom-kill thrashing 
4. system DOES respond to SysReq S/U/B recipe

Expected results:
<heh> shouldn't gobble all the world's memory

Additional info:
from cat cpuinfo..
 AuthenticAMD
 cpu family      : 15
 model           : 47
 model name      : AMD Athlon(tm) 64 Processor 3500+
 stepping        : 0
 cpu MHz         : 2210.202
 cache size      : 512 KB

Normal memory stats:
free -m
             total       used       free     shared    buffers     cached
Mem:          1004        580        423          0         25        282
-/+ buffers/cache:        272        732
Swap:          972          0        972

Most recent yum updates
 Apr 13 23:13:53 Updated: plone.x86_64 2.1.2-2.fc4
 Apr 13 23:14:43 Updated: abiword.x86_64 1:2.4.4-2.fc4
 Apr 14 19:42:47 Updated: gnochm.noarch 0.9.7-4.fc4
Most recent manual installs (reverse-chron):
 python-sqlite2-2.1.3-4
 sqlite-3.3.3-1.2
 lighttpd-1.4.11-1.x86_64.rpm
 python-urlgrabber-2.9.8-2.noarch.rpm
 linkchecker-3.4-1.x86_64.rpm
Comment 1 Seth Vidal 2006-04-18 23:50:08 EDT
why'd you install sqlite 3.3.3?

b/c that's what's causing the memory overrun.
Comment 2 James G. Sack 2006-04-19 02:24:00 EDT
Whoa! How did you pinpoint that? That seemed to be it. I did a rpm --oldpackage back 
to sqlite-3.1.2-3 (from FC4) and yum works now.

To answer your question: I had some thought of upgrading python-sqlite2, and seemed to 
<accidentally> grab the 2.2.1.3 version from FC5. Then when it griped about needing 
sqlite3.3, I thought I would be safe installing the FC5 sqlite3.3 if I compiled it in 
my environment -- guess that may have been an incorrect assumption <grin>.

So ... problem is resolved..

..but I still want to know how you knew? 

My sincere respects!!
And warm thanks for the prompt feedback, too.

..jim
Comment 3 Seth Vidal 2006-04-19 07:49:07 EDT
It's been reported before. Paul Nasrat discovered it. I just read it.

:)


Note You need to log in before you can comment on or make changes to this bug.