Bug 189324 - Error when compiling against glibc-kernheaders
Error when compiling against glibc-kernheaders
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 02:27 EDT by Paul F. Johnson
Modified: 2008-01-06 16:31 EST (History)
2 users (show)

See Also:
Fixed In Version: Fedora 7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 16:31:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2006-04-19 02:27:19 EDT
Description of problem:
Whilest compiling mono-debugger (and anjuta2), the build process throws up an
error - expected specifier-qualifier-list before 'u64'

Version-Release number of selected component (if applicable):
3.0-5.2

How reproducible:
Always

Steps to Reproduce:
1. Download the source to mono-debugger
(http://www.smmp.salford.ac.uk/packages/mono-debugger-0.12-2.src.rpm)
2. Install and try to compile
3.
  
Actual results:
The build throws up

In file included from /usr/include/asm/user.h:4,
                 from x86_64-arch.h:10,
                 from x86-arch.h:45,
                 from x86-linux-ptrace.h:4,
                 from x86-ptrace.c:35:
/usr/include/asm-x86_64/user.h:56: error: expected specifier-qualifier-list
before 'u64'

Expected results:
mono-debugger should compile

Additional info:
The compile works fine on an x86 box, just not on an x86_64
Comment 1 Jason Tibbitts 2006-04-28 21:29:09 EDT
I went to take a look at this but the link above is invalid; I grabbed
http://www.smmp.salford.ac.uk/packages/mono-debugger-0.12-3.src.rpm instead but
it fails to build due to a missing BuildRequire: glib2-devel, mono-devel.  I
added that and handed it to mock (development, x86_64).  Everything compiles
fine but the package fails to build completely due to errors in the %file section.

So at least this is not a problem in rawhide.  It does indeed fail as advertised
in FC5.

Comment 2 Jason Tibbitts 2006-04-28 21:33:29 EDT
BTW, the rawhide version of /usr/include/asm-x86_64/user.h has
double-underscores in front of the problematic types in that structure definition:

rawhide:

struct user_i387_struct {
        unsigned short  cwd;
        unsigned short  swd;
        unsigned short  twd; /* Note this is not the same as the 32bit/x87/FSAVE
twd */
        unsigned short  fop;
        __u64   rip;
        __u64   rdp;
        __u32   mxcsr;
        __u32   mxcsr_mask;
        __u32   st_space[32];   /* 8*16 bytes for each FP-reg = 128 bytes */
        __u32   xmm_space[64];  /* 16*16 bytes for each XMM-reg = 256 bytes */
        __u32   padding[24];
};

FC5:

struct user_i387_struct {
        unsigned short  cwd;
        unsigned short  swd;
        unsigned short  twd; /* Note this is not the same as the 32bit/x87/FSAVE
twd */
        unsigned short  fop;
        u64     rip;
        u64     rdp;
        u32     mxcsr;
        u32     mxcsr_mask;
        u32     st_space[32];   /* 8*16 bytes for each FP-reg = 128 bytes */
        u32     xmm_space[64];  /* 16*16 bytes for each XMM-reg = 256 bytes */
        u32     padding[24];
};
Comment 3 David Woodhouse 2006-06-02 10:39:01 EDT
Reopening -- still exists in FC5.
Comment 4 Paul F. Johnson 2006-06-02 10:46:40 EDT
Um, I've not seen it when compiling on my vanilla box - there are certainly
warnings, but mono-debugger is compiling fine (which is where I found this
problem initially)
Comment 5 David Woodhouse 2006-06-02 10:56:03 EDT
I don't think I ever fixed glibc-kernheaders though.
Comment 6 Paul F. Johnson 2006-06-02 11:00:09 EDT
Something has...

Dammit. I did! Just checked my logs!!!
Comment 7 Paul F. Johnson 2006-06-08 04:05:06 EDT
Can this bug now be closed as the headers have been pushed to both rawhide and FC5?
Comment 8 David Woodhouse 2006-06-08 05:24:05 EDT
They still haven't been pushed to FC5. See comment #5. And comment #6.
Comment 9 Paul F. Johnson 2006-06-08 05:31:01 EDT
Ah. My apologies. I thought that they were going to be pushed shortly before the
RH pow-wow.
Comment 10 David Woodhouse 2006-06-08 05:57:56 EDT
There's still an occasional problem with them trickling in, and I want to ship
the proper 2.6.17 headers, preferably after Linus has taken the 'make
headers_install' thing into 2.6.18. So another week or two, I think.
Comment 11 Konrad Rzeszutek 2006-09-08 13:04:41 EDT
Hey David.

There also seems to be missing: /usr/include/linux/compiler.h file.
Comment 13 David Woodhouse 2006-09-09 01:35:49 EDT
linux/compiler.h is intentionally absent and not relevant to this bug.
Comment 14 Till Maas 2008-01-06 16:31:26 EST
According to the comments this should be fixed in current Fedora releases.

Note You need to log in before you can comment on or make changes to this bug.