Bug 1893332 - Issues building fizz as a static library on some architectures
Summary: Issues building fizz as a static library on some architectures
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fizz
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-30 18:27 UTC by Michel Alexandre Salim
Modified: 2022-03-26 15:16 UTC (History)
3 users (show)

Fixed In Version: fizz-2022.03.07.00-1.fc37 fizz-2022.03.07.00-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-09 20:22:22 UTC
Type: Bug


Attachments (Terms of Use)
armv7hl build failure with shared fizz trying to link against static folly (90.99 KB, text/plain)
2020-10-30 18:27 UTC, Michel Alexandre Salim
no flags Details
ppc64le f32 build failure when static build is enabled (55.24 KB, text/plain)
2020-10-30 18:33 UTC, Michel Alexandre Salim
no flags Details
aarch64 build failure (F33) with shared fizz trying to link against static folly (318.13 KB, text/plain)
2020-10-30 18:34 UTC, Michel Alexandre Salim
no flags Details
aarch64 build failure (F34) with shared fizz trying to link against static folly (318.13 KB, text/plain)
2020-10-30 18:34 UTC, Michel Alexandre Salim
no flags Details

Description Michel Alexandre Salim 2020-10-30 18:27:14 UTC
Created attachment 1725364 [details]
armv7hl build failure with shared fizz trying to link against static folly

Description of problem:
We want to have the stack of Facebook C++ libraries available both as shared and static libraries; because there is no guarantee of ABI stability we bump the shared library soname every release, so any usage from outside Fedora packages probably want to use the static libraries anyway.

When building fizz, we thus need to have both folly-devel and folly-static available. This works reliably on x86_64.

On armv7hl and aarch64, though, when building for F33 and F34 the shared build attempts to link against libfolly.a which fails because libfolly.a was not built with -fPIC:
- F33 https://koji.fedoraproject.org/koji/taskinfo?taskID=54526861
- F34 https://koji.fedoraproject.org/koji/taskinfo?taskID=54525362

(armv7hl static build was already disabled when it failed in a scratch build, so the build passed above because folly-static was not installed. Will upload the scratch log later)

Bizarrely, on F32 aarch64 succeeded ... but ppc64 failed with a different final link error. It succeeded on F33 and F34

- F32 https://koji.fedoraproject.org/koji/taskinfo?taskID=54568825

Version-Release number of selected component (if applicable):
2020.10.26.00-2

How reproducible:
Always

Steps to Reproduce:
1. fedpkg clone fizz
2. cd fizz
3. git checkout 688dad0af01b5bd03f43dcba87d836d09ce53062
4. fedpkg srpm
5. koji build --scratch f34 fizz-2020.10.26.00-2.fc34.src.rpm
6. repeat for F33 and F32

Actual results:
Failed as above

Expected results:
These should succeed

Additional info:

Comment 1 Michel Alexandre Salim 2020-10-30 18:33:35 UTC
Created attachment 1725366 [details]
ppc64le f32 build failure when static build is enabled

Comment 2 Michel Alexandre Salim 2020-10-30 18:34:09 UTC
Created attachment 1725367 [details]
aarch64 build failure (F33) with shared fizz trying to link against static folly

Comment 3 Michel Alexandre Salim 2020-10-30 18:34:46 UTC
Created attachment 1725368 [details]
aarch64 build failure (F34) with shared fizz trying to link against static folly

Comment 4 Ben Cotton 2021-02-09 15:22:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 5 Fedora Update System 2022-03-09 20:18:39 UTC
FEDORA-2022-5852540ea0 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-5852540ea0

Comment 6 Fedora Update System 2022-03-09 20:20:04 UTC
FEDORA-2022-737d681400 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-737d681400

Comment 7 Fedora Update System 2022-03-09 20:22:22 UTC
FEDORA-2022-737d681400 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2022-03-11 19:23:42 UTC
FEDORA-2022-5852540ea0 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-5852540ea0`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-5852540ea0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-03-26 15:16:14 UTC
FEDORA-2022-5852540ea0 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.