Bug 189335 - user mouse button/wheel activity does not exit screensaver
user mouse button/wheel activity does not exit screensaver
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 05:52 EDT by David Timms
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.14.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-03 21:41:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Timms 2006-04-19 05:52:59 EDT
Description of problem:
Once screensaver is active, mouse clicks (left/right/both/wheel click) and mouse
wheel rolling does not exit the screensaver.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.14.1-1.fc5.1
{xscreensaver-base-4.24-2
xscreensaver-extras-4.24-2
xscreensaver-gl-extras-4.24-2}

How reproducible:
Everytime with at least the screensavers: blue squares|space images|floaters.

Steps to Reproduce: (quickly)
1. System|Preferences|Screensaver|Set session idle after 1 minute.
2. uncheck lock screen saver when active.
3. wait until screensaver begins.
4. click or roll mouse wheel (without moving mouse).

Actual results:
screensaver continues...

Expected results:
screensaver exits, returning to what you were viewing when the ss kicked in.

Additional info:
The release listed (and one before it) fixed the bug 186772 where the same mouse
actuations continually were not keeping the fade to black starting nor
screensaver starting.

It is probably uncommon for people to try to exit the screensaver by clicking
mouse buttons; though it is easy to do on a touchpad on a notebook, and with
some optical mice.
Comment 1 jmccann 2006-04-26 13:07:28 EDT
Fixed in upstream gnome-2-14 and HEAD.
Comment 2 Ray Strode [halfline] 2006-05-01 14:17:06 EDT
Hi David,

Are you still seeing this with the latest updates?
Comment 3 David Timms 2006-05-02 09:13:12 EDT
Ray, as @ 2006-06-02
with normal updates, no change. 
with updates-testing, no change:
# rpm -qa|grep -E 'screensaver|hal|power'|sort
gnome-power-manager-2.14.3-1
gnome-screensaver-2.14.1-1.fc5.1
hal-0.5.7-3.fc5.1
hal-cups-utils-0.5.5-1.2
hal-devel-0.5.7-3.fc5.1
hal-gnome-0.5.7-3.fc5.1
xscreensaver-base-4.24-2
xscreensaver-extras-4.24-2
xscreensaver-gl-extras-4.24-2

with development, no change:
gnome-power-manager-2.15.1-1
gnome-screensaver-2.14.1-2
hal-0.5.7-5
hal-cups-utils-0.5.5-1.2
hal-devel-0.5.7-5
hal-gnome-0.5.7-5
xscreensaver-base-4.24-2
xscreensaver-extras-4.24-2
xscreensaver-gl-extras-4.24-2
---
Looks like William has made changes lately:
http://cvs.gnome.org/viewcvs/gnome-screensaver/ChangeLog?rev=1.453&view=log
2006-04-26  William Jon McCann  <mccann@jhu.edu>

	* src/gs-window-x11.c: (maybe_request_unlock),
	(gs_window_real_key_press_event),
	(gs_window_real_motion_notify_event),
	(gs_window_real_button_press_event), (gs_window_real_scroll_event),
	(gs_window_class_init):
	Make button presses and scroll events request an unlock.

I also tried with screen-saver set to lock (ie need password to exit), noGo.

Ray, have you pulled in the new code and made an rpm already ? where ?   DaveT.
Comment 4 Ray Strode [halfline] 2006-05-02 10:11:19 EDT
Hi, 

In fact I haven't.  Sorry about that.  I thought I had, but I got sidetracked. 
Anyway, I'll have a look today.
Comment 5 jmccann 2006-06-02 16:09:52 EDT
David, this should be fixed with updates by now.  Can you confirm?
Comment 6 David Timms 2006-06-03 21:41:10 EDT
With: Jun 01 18:38:47 Updated: gnome-screensaver.i386 2.14.2-1
This is the one in updates/testing/5/i386

Test: set screensaver timeout to 1 minute. Don't move mouse (hold it in air!),
after fade out and screensaver (random) running:
1. left-click: Exits OK
2. right-click: Exits OK
3. scroll Up: Exits OK
4. scroll Down: Exits OK
5. scroll Click: Exits OK.

Confirming fixed with the above version. Someone with a mouse with more
buttons/features might like to confirm, but I'll mark it closed/errata, although
the signed package has not made it to updates yet (is this correct ?).

Good work to both developers and packagers :)

Since I am not sure which packages come into play, I'll list them for later ref:
rpm -qa|grep -E 'screen|hal|power'|sort
gnome-power-manager-2.15.1-1  *from devel
gnome-screensaver-2.14.2-1    *from updates-testing
hal-0.5.7-5
hal-gnome-0.5.7-5
xscreensaver-base-4.24-2
xscreensaver-extras-4.24-2
xscreensaver-gl-extras-4.24-2

Note You need to log in before you can comment on or make changes to this bug.