Bug 189348 - make pykickstart aware of kickstart options introduced with new fc/rhel versions
make pykickstart aware of kickstart options introduced with new fc/rhel versions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 09:16 EDT by James Martin
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-16 14:34:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Martin 2006-04-19 09:16:15 EDT
I know this may be out of scope for the module, but it was an idea anyhow..

Right now pykickstart supports options for kickstart files that don't exist for
all fc/rhel versions.

It would be nice if pyckistart was aware of what version of rhel/fc you were
writing the kickstart file for so that it would only expose the available
options-- This way you could have one program that could write kickstart files
for a bunch of different versions without putting in options that anaconda
couldn't parse because it's not aware.

I guess one would to do it is assign some sort of key -- maybe ksdata.version
that would define the version of rhel/fc you are using, and then add meta data
to the options so they are aware of what versions that should work with..

As of right now with my program I'm more or less stripping out of the text that
pykickstart creates all the options that shouldn't be available, there's got to
be a better way.
Comment 4 Chris Lumens 2007-01-16 14:34:55 EST
Well, that was a lot of work.

pykickstart-0.90-1 has been built, which contains this functionality.  There's
still things to do like deciding on a final format for version strings, adding
support for various RHEL releases, making a devel syntax version for F7,
updating the programmers-guide, and so forth.  However I'm going to close this
bug since the functionality is now there.  Undoubtedly, there are going to be
bugs in this (or in anaconda, or s-c-ks because of this).  Please file those
separately to make it easier to deal with, rather than adding a bunch of stuff
to this bug.
Comment 5 James Martin 2007-01-16 17:21:15 EST
Thanks for the hard work.. I will get cracking on it soon!

Note You need to log in before you can comment on or make changes to this bug.