Bug 189365 - Manage Channel Family tools support
Manage Channel Family tools support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
rhn420
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
:
Depends On:
Blocks: rhn-content-mgmt-m1
  Show dependency treegraph
 
Reported: 2006-04-19 10:52 EDT by Pradeep Kilambi
Modified: 2007-04-18 13:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhn500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 11:16:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2006-04-19 10:52:00 EDT
Description of problem:

1. Modify,redesign manage channel family tool.

2. Client side redesign and support. Modify the available
create-channel-family.py to use xmlrpc rather than direct db.

3.Deprecate any perl scripts available( None in this case)

4. Server side handlers support.(ex: /App ,/redhat_xmlrpc ) to enable xmlrpc
response.

5. configs could be combined with manage-channel tool

6. man pages needed.

7. inclusion into satellite -> possibly considered for custom channel creations.
Comment 1 Pradeep Kilambi 2006-05-03 14:41:15 EDT
> 7. inclusion into satellite -> possibly considered for custom channel creations.

This tool is not intended for satellite. It is hosted only tool.
Comment 2 Pradeep Kilambi 2006-06-27 16:15:29 EDT
tool is completed and is in beta state
Comment 3 Pradeep Kilambi 2006-06-28 09:47:27 EDT
This tool is a hosted only tool

rhn-manage-channel-family-internal -> hosted

- man pages added

- unit tests added to both client and server

Note You need to log in before you can comment on or make changes to this bug.