Bug 1893734 - collect2: fatal error: ld terminated with signal 11 [Segmentation fault]
Summary: collect2: fatal error: ld terminated with signal 11 [Segmentation fault]
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Nick Clifton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1893664 (view as bug list)
Depends On:
Blocks: F34FTBFS PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-02 13:38 UTC by Tomáš Hrnčiar
Modified: 2020-11-09 09:51 UTC (History)
15 users (show)

Fixed In Version: binutils-2.35.1-12.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-09 09:51:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-02 13:38:56 UTC
Hello,

I am unable to build scipy, it fails with this error:

In file included from scipy/integrate/_quadpackmodule.c:4:
scipy/integrate/__quadpack.h: In function ‘quad_thunk’:
scipy/integrate/__quadpack.h:312:9: warning: ‘PyEval_CallObjectWithKeywords’ is deprecated [-Wdeprecated-declarations]
  312 |         res = PyEval_CallObject(callback->py_function, arglist);
      |         ^~~
In file included from /usr/include/python3.10/Python.h:146,
                 from scipy/integrate/__quadpack.h:23,
                 from scipy/integrate/_quadpackmodule.c:4:
/usr/include/python3.10/ceval.h:17:43: note: declared here
   17 | Py_DEPRECATED(3.9) PyAPI_FUNC(PyObject *) PyEval_CallObjectWithKeywords(
      |                                           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/usr/bin/gfortran -Wall -g -Wall -g -shared build/temp.linux-x86_64-3.10/scipy/integrate/_quadpackmodule.o -L/usr/lib64 -L/usr/lib/gcc/x86_64-redhat-linux/10 -L/usr/lib/gcc/x86_64-redhat-linux/10 -L/usr/lib64 -Lbuild/temp.linux-x86_64-3.10 -Wl,-rpath=/usr/lib64 -lquadpack -lmach -lflexiblas -lflexiblas -lgfortran -o build/lib.linux-x86_64-3.10/scipy/integrate/_quadpack.cpython-310-x86_64-linux-gnu.so -Wl,--version-script=build/temp.linux-x86_64-3.10/link-version-scipy.integrate._quadpack.map
collect2: fatal error: ld terminated with signal 11 [Segmentation fault], core dumped
compilation terminated.
error: Command "/usr/bin/gfortran -Wall -g -Wall -g -shared build/temp.linux-x86_64-3.10/scipy/integrate/_quadpackmodule.o -L/usr/lib64 -L/usr/lib/gcc/x86_64-redhat-linux/10 -L/usr/lib/gcc/x86_64-redhat-linux/10 -L/usr/lib64 -Lbuild/temp.linux-x86_64-3.10 -Wl,-rpath=/usr/lib64 -lquadpack -lmach -lflexiblas -lflexiblas -lgfortran -o build/lib.linux-x86_64-3.10/scipy/integrate/_quadpack.cpython-310-x86_64-linux-gnu.so -Wl,--version-script=build/temp.linux-x86_64-3.10/link-version-scipy.integrate._quadpack.map" failed with exit status 1
error: Bad exit status from /var/tmp/rpm-tmp.J0N25t (%build)
    Bad exit status from /var/tmp/rpm-tmp.J0N25t (%build)

I have tried to build it in Koji, Copr also in Mock, but everywhere same segfault. Here is the link for Koji:

https://koji.fedoraproject.org/koji/taskinfo?taskID=54764233

Comment 1 Nikola Forró 2020-11-02 13:44:38 UTC
I just got a notification from Koschei. It seems that binutils update broke quite a lot of packages (including scipy):
https://koschei.fedoraproject.org/affected-by/binutils?epoch1=0&version1=2.35.1&release1=8.fc34&epoch2=0&version2=2.35.1&release2=11.fc34&collection=f34

Comment 2 Miro Hrončok 2020-11-02 13:57:29 UTC
I'll start a thread on devel.

Comment 4 Zbigniew Jędrzejewski-Szmek 2020-11-02 14:37:09 UTC
*** Bug 1893664 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2020-11-02 15:31:31 UTC
Setting severity to high, this affects dozens of packages including rpm.

Comment 6 Nick Clifton 2020-11-03 13:43:23 UTC
A fix is in the works.  Build should complete in ~ 1 hour.

Comment 7 Nick Clifton 2020-11-03 15:23:14 UTC
Fixed in binutils-2.35.1-12.fc34

Sorry about that guys.  My -11.fc34 update was broken and it took me a while to track down the problem.
Please try the -12.fc34 binutils - they should work properly.

Comment 8 Miro Hrončok 2020-11-03 17:22:40 UTC
It appears to be fixed in binutils 2.35.1-12.fc34

At least rpm and scipy* build again. Thanks for the fix.



* scipy successfully passed the %build phase on x86_64

Comment 9 Christoph Junghans 2020-11-06 16:16:27 UTC
Still segfaults, now inside using clang++-11:
Program received signal SIGSEGV, Segmentation fault.
0x00007fb81e40aa88 in bfd_elf_link_add_symbols () from
/usr/lib64/libbfd-2.35.1-11.fc34.so
(gdb) bt
#0  0x00007fb81e40aa88 in bfd_elf_link_add_symbols () from
/usr/lib64/libbfd-2.35.1-11.fc34.so
#1  0x000055745267e16c in load_symbols.part ()
#2  0x000055745267304c in open_input_bfds.lto_priv ()
#3  0x0000557452673116 in open_input_bfds.lto_priv ()
#4  0x000055745267b538 in lang_process ()
#5  0x000055745266bf97 in main ()
(from building votca-xtp with clang-11 on rawhide)

To reproduce, run:
$ docker run -it fedora:rawhide /bin/bash
in the container
$ dnf install git cmake eigen3-devel libint2-devel hdf5-devel
libxc-devel expat-devel boost-devel
$ git clone --recursive https://github.com/votca/votca
$ cmake -B build -DBUILD_XTP=ON votca
$ cmake --build build
....wait and see the segfault.

Comment 10 Nick Clifton 2020-11-06 17:04:40 UTC
(In reply to Christoph Junghans from comment #9)

> Still segfaults, now inside using clang++-11:
> To reproduce, run:
> $ docker run -it fedora:rawhide /bin/bash
> in the container
> $ dnf install git cmake eigen3-devel libint2-devel hdf5-devel
> libxc-devel expat-devel boost-devel
> $ git clone --recursive https://github.com/votca/votca
> $ cmake -B build -DBUILD_XTP=ON votca
> $ cmake --build build
> ....wait and see the segfault.

Err, I just tried that, and there was no seg-fault....

Actually to be strictly accurate I used a mock chroot instead of a container, but it was still based on rawhide.
I'll try using docker and see if that makes the problem happen.

Comment 11 Miro Hrončok 2020-11-06 17:15:29 UTC
The log says: 2.35.1-11.fc34

You need to get the updated 2.35.1-12.fc34. It is not yet on the mirrors.

Comment 12 Miro Hrončok 2020-11-09 09:51:44 UTC
This is on the mirrors.


Note You need to log in before you can comment on or make changes to this bug.