Bug 18939 - Error in shared library with real server.
Summary: Error in shared library with real server.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-12 09:46 UTC by Nicolas CROISET
Modified: 2016-11-24 15:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-06 18:19:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolas CROISET 2000-10-12 09:46:58 UTC
Hello,

when I want ot launch the binary from REAL Networks to install a real server version 7.0 I have this error message.

ncroiset]# ./g2_7_0update2-linux-c6.bin
./g2_7_0update2-linux-c6.bin: error while loading shared libraries: ./g2_7_0update2-linux-c6.bin: undefined symbol: __eh_pc
[root@pc-1 ncroiset]#

I have update glibc with glibc-2.1.94-3.i386.rpm

Bye.

Comment 1 Jakub Jelinek 2000-10-12 09:57:42 UTC
Can you please run ./g2_7_0update2-linux-c6.bin to see which libraries was
it linked against? __eh_pc symbol was removed from libgcc.a a very long time
ago (Dec 1997) but it is still present in several of our libstdc++ compatibility
libraries.

Comment 2 Nicolas CROISET 2000-10-12 12:18:47 UTC
ldd g2_7_0update2-linux-c6.bin
        /lib/libNoVersion.so.1 => /lib/libNoVersion.so.1 (0x40017000)
        libdl.so.2 => /lib/libdl.so.2 (0x4001e000)
        libstdc++.so.2.8 => /usr/lib/libstdc++.so.2.8 (0x40021000)
        libm.so.6 => /lib/libm.so.6 (0x40064000)
        libc.so.6 => /lib/libc.so.6 (0x40083000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)



Comment 3 Ulrich Drepper 2003-10-03 09:14:55 UTC
I guess this is no problem anymore due to obsolete code.  I'll close the bug
soon unless I hear otherwise.

Comment 4 Ulrich Drepper 2003-11-06 18:19:11 UTC
Haven't heard anything in a month.  Closing.


Note You need to log in before you can comment on or make changes to this bug.