Bug 189407 - grub hangs at "Loading stage 1.5"
grub hangs at "Loading stage 1.5"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 15:27 EDT by petri.poyhonen
Modified: 2008-05-06 11:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:48:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petri.poyhonen 2006-04-19 15:27:41 EDT
Description of problem:
FC5 does not boot after a succesful installation (and a second successful
reinstallation).  I have installed FC5 to two other boxes successfully, this one
fails.  It is Intel Celeron 1.8G with AMIBIOS.

Version-Release number of selected component (if applicable):
GRUB grub-0.97-5.i386.rpm


How reproducible:
Always there.

Steps to Reproduce:
1. Install FC5 from iso cds.
2. Boot
3.
  
Actual results:
GRUB reports: "GRUB Loading stage 1.5" and "GRUB loading, please wait..."


Expected results:
FC5 should have fired up.

Additional info:
I have tried all the usual tricks:

I have used grub:
root (hd0,0)
setup (hd0)
This completes successfully.  The only difference is that after this GRUB
reports loading Stage 2.

I have used the rescue cd to boot the system and used grub-install /dev/hda.
This completes successfully.

I have also downloaded an older version of grub (the one for FC4, 
grub-0.95-13.i386.rpm), no difference.
I have no downloaded a fresh copy of GRUB grub-0.97-5.i386.rpm and had it
reinstalled.  No help.

I have studied this page
http://readlist.com/lists/redhat.com/fedora-list/13/67717.html
reporting a special behaviour of AMIBIOS, when first boot device was set to DVD
(and boot from HDD was then tried).  I have defined HDD as my first boot device,
no impact.

I can see one anomaly: grub commend find fails to find files.  find vmlinuz
returns "File not found".

I tried this in my other FC5 machine, which boots successfully, the same here. 
grub does not find files (still that machine boots).
Comment 1 petri.poyhonen 2006-04-23 11:03:56 EDT
More context information:
After booting with rescue cd and chroot /mnt/sysimage ...

grub> root (hd0,1)
 Filesystem type unknown, partition type 0x8e
grub> root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
grub> find /grub/stage1
(hd0,0)
grub> find stage1

Error 15: File not found

grub> kernel (hd0,0)/vmlinuz-2.6.15-1.2054_FC5 ro root=/dev/VolGroup00/LogVol00
rhgb quiet
   [Linux-bzImage, setup=0x1e00, size 0x16eb71]
grub> initrd (hd0,0)/initrd-2.6.15-1.2054_FC5.img

Error 28: Selected item cannot fit into memory

*****

As we can see, find works, if file paths are complete.  Grub does not search for
filenames matching the string.

I do not know, whether grub not being able to read (hd0,1), the root partition,
is an anomaly.  Apparently the root partition is perfectly alright after booting
with rescue cd.

What looks like a clear problem is that initrd is not able to process the
ramdisk image.  Would this develop into a problem before we should see the
splash screen ?
Comment 2 petri.poyhonen 2006-05-01 11:10:04 EDT
My hardware is Compaq Evo D510 e-pc, vintage 2002.

Interesting enough, I became aware of a mother board dip switch:
ON Bootblock protected (default)
OFF Bootblock not protected

I connected this to the OFF stage.  This has hadno visible impact to my failing
attempts to get grub installed and my system fired up.

System does not boot (has never booted).

Boot from rescue cd, chroot /mnt/sysimage.

grub> root (hd0,0)
grub> setup (hd0)
Checking if "/boot/grub/stage1" exists... no
Checking if "/grub/stage1" exists... yes
Checking if "/grub/stage2" exists... yes
Checking if "/grub/e2fs_stage1_5" exists... yes
Running "embed /grub/e2fs_stage1_5 (hd0)"... 15 sectors are embedded succeeded.
Running "install /grub/stage1 (hd0) (hd0)1+15 p (hd0,0)/grub/stage2
/grub/grub.conf" ... succeeded.
Done

This just confirms that grub installation with commend shell apparently
succeeds, but the system would not boot.

Next I hid stage1.5

# mv /boot/grub/e2fs_stage1_5 /boot/grub/e2fs_stage1_5.bak

>grub 

grub> root (hd0,0)
grub> setup (hd0)
Checking if "/boot/grub/stage1" exists... no
Checking if "/grub/stage1" exists... yes
Checking if "/grub/stage2" exists... yes
Checking if "/grub/e2fs_stage1_5" exists... no
Running "install /grub/stage1 (hd0) /grub/stage2 p /grub/grub.conf" ... succeeded
Done

Now the system should be skipping stage 1.5.
No progress.  System hangs at "Loading stage2 ..."

# grub-install --version
grub-install (GNU GRUB 0.97)

Comment 3 petri.poyhonen 2006-05-06 03:56:22 EDT
Update:

I have flashed an update to the bios, AMIBIOS JK.01.01 - JK.01.05
Installed Windows XP, works fine.

Re-installed FC5.
No progress.  Grub continues to hang when loading stage2.

Any ideas, where to go next ?





Comment 4 Bug Zapper 2008-04-03 22:41:24 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 5 Bug Zapper 2008-05-06 11:48:42 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.