Bug 1894129 - [Testday] Workloads-> Virtualization is not loading for Firefox browser
Summary: [Testday] Workloads-> Virtualization is not loading for Firefox browser
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.z
Assignee: Yaacov Zamir
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On: 1893963
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-03 15:42 UTC by OpenShift BugZilla Robot
Modified: 2021-01-08 15:11 UTC (History)
2 users (show)

Fixed In Version: 4.6.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-16 14:37:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 7085 0 None closed [release-4.6] Bug 1894129: Dont use lookbehinds regexp 2020-11-11 07:09:58 UTC
Red Hat Product Errata RHBA-2020:4987 0 None None None 2020-11-16 14:38:00 UTC

Description OpenShift BugZilla Robot 2020-11-03 15:42:08 UTC
+++ This bug was initially created as a clone of Bug #1893963 +++

Description of problem:
tested with Firefox 68.12.0esr (64-bit) and  66.0.2 (64-bit) when going to the Virtualization tab in the UI nothing is loading on the right side 

Version-Release number of selected component (if applicable):
OCP-4.6/CNV-2.5

How reproducible:
Happened on 2 different environments, to 2 different testers

--- Additional comment from istein@redhat.com on 2020-11-03 08:22:28 UTC ---

This bug was reported during the "Migration to Openshift Virtualization Test day" on Oct 20 2020.

--- Additional comment from istein@redhat.com on 2020-11-03 09:37:07 UTC ---

Screenshot: https://drive.google.com/file/d/1gBRG5WCbn46Vyh0CK27AeMqg16Jx_jZg/view?usp=sharing

--- Additional comment from yzamir@redhat.com on 2020-11-03 12:13:23 UTC ---

Note:
FireFox 68 does not support lookbehinds regular expresions.

We introduced such query in https://bugzilla.redhat.com/show_bug.cgi?id=1879054
https://github.com/openshift/console/blob/master/frontend/packages/kubevirt-plugin/src/components/vms/vm-console.tsx#L86

Comment 3 Ilanit Stein 2020-11-11 11:54:47 UTC
@Yaacov,

What is the "Fixed in version" please?

Comment 4 Yaacov Zamir 2020-11-11 12:48:59 UTC
set 4.6.4 using https://errata.devel.redhat.com/advisory/65844

Comment 5 Ilanit Stein 2020-11-12 17:03:00 UTC
Verified using OCP 4.6.4 (Upgraded 4.6.1 to 4.6.4) 
Tested on Firefox 66.0.4 (64-bit)
Before upgrade the Virtualization content was not displayed
and after the upgrade content was displayed.

Also checked for reference a cluster with OCP-4.6.3, 
with same Firefox version, and saw the Virtualization content was not displayed.

Comment 7 errata-xmlrpc 2020-11-16 14:37:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.4 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4987


Note You need to log in before you can comment on or make changes to this bug.