Bug 189419 - AMD64 Firefox breaks several popular sites that work in i386 Firefox
AMD64 Firefox breaks several popular sites that work in i386 Firefox
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 17:08 EDT by Nicholas Miell
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 20:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the starting state (20.71 KB, image/png)
2006-04-19 17:08 EDT, Nicholas Miell
no flags Details
the end result of navigating down once in a good Firefox (21.54 KB, image/png)
2006-04-19 17:09 EDT, Nicholas Miell
no flags Details
what actually happens in Fedora builds (18.49 KB, image/png)
2006-04-19 17:09 EDT, Nicholas Miell
no flags Details

  None (edit)
Description Nicholas Miell 2006-04-19 17:08:20 EDT
Some interaction between Firefox 1.5.0.2 and Fedora's patches (or build options)
is breaking Google Reader.

I've tested this with several versions of Firefox (starting from empty
profiles), and I'm pretty confident in my assignment of blame. (AMD64
firefox-1.5.0.2-1.1.fc5: broken; i386 firefox-1.5.0.2-3: broken; the official
i686/Linux Firefox 1.5.0.2: works fine)

To reproduce: go to reader.google.com, subscribe to a few feeds, switch "Read
items" from hidden to visible (so you have some history to work with), and then
start clicking on up/down or pressing j/k.

Instead of smoothly navigating to the next or previous item in your reading
list, Reader will stop part way through the operation or jump around somewhat
randomly.

I'm attaching some screenshots to illustrate the problem.
Comment 1 Nicholas Miell 2006-04-19 17:08:20 EDT
Created attachment 128007 [details]
the starting state
Comment 2 Nicholas Miell 2006-04-19 17:09:22 EDT
Created attachment 128008 [details]
the end result of navigating down once in a good Firefox
Comment 3 Nicholas Miell 2006-04-19 17:09:53 EDT
Created attachment 128009 [details]
what actually happens in Fedora builds
Comment 4 Nicholas Miell 2006-04-19 17:23:22 EDT
I retested with firefox-1.5.0.2-1.2.fc5 and this bug still exists.
Comment 5 Nicholas Miell 2006-04-23 21:26:35 EDT
running with MOZ_DISABLE_PANGO doesn't help
Comment 6 Nicholas Miell 2006-05-12 19:58:38 EDT
still happens in firefox-1.5.0.3-1.1.fc5
Comment 7 Nicholas Miell 2006-05-31 00:07:58 EDT
The new Yahoo redesign (just about everything dynamic on the page -- click on
the content tabs, click on the "All Yahoo! Services" button, mouse over the
Mail/Weather/etc. buttons on the right) and the new slashdot redesign (the
sidebar expanders and login expander) are also broken in Fedora's Firefox.

It looks like anything that dynamically resizes content breaks, although I think
there's more to it than that.
Comment 8 Nicholas Miell 2006-06-03 02:34:19 EDT
The custom scrolling widgets on www.nintendo.com are also broken.
Comment 9 Nicholas Miell 2006-06-15 19:47:48 EDT
firefox-1.5.0.4-1.2.fc5 is also broken
Comment 10 Nicholas Miell 2006-08-09 19:05:56 EDT
firefox-1.5.0.6-2.fc5 still broken
Comment 11 Nicholas Miell 2006-09-16 19:13:21 EDT
firefox-1.5.0.7-1.fc5 is still broken
Comment 12 Warren Togami 2006-09-17 11:52:34 EDT
firefox-1.5.0.7-1.fc6 seems to work without these problems...
Comment 13 Nicholas Miell 2006-09-17 14:18:51 EDT
I tried it again with a new profile and it's still broken. 
I also tried it with the official Mozilla Firefox build, and it still works.

I also tried it with the i386 Fedora version, and it works.
So I guess the guy I conned into testing i386 Firefox was wrong and this is only
an AMD64 problem, and not necssarily only with Fedora -- it's just that Fedora
is the only OS shipping an AMD64 Firefox.

The fastest way to reproduce the bug these days is to go to www.nintendo.com,
navigate past the "You don't have Flash" page, and then click on the scroll
arrows in the Hot News box on the lower left of the front page. The first click
will sort of scroll it (but not as much as a functional version of Firefox), and
each additional click will do nothing.
Comment 14 Nicholas Miell 2006-10-28 20:57:42 EDT
Appears to be fixed in Firefox 2.

Note You need to log in before you can comment on or make changes to this bug.