Bug 1894227 - Console shows wrong value for maxUnavailable and maxSurge when set to 0
Summary: Console shows wrong value for maxUnavailable and maxSurge when set to 0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1894110
Blocks: 1896990
TreeView+ depends on / blocked
 
Reported: 2020-11-03 18:47 UTC by OpenShift BugZilla Robot
Modified: 2020-11-30 16:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-30 16:45:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 7090 0 None closed [release-4.6] Bug 1894227: Handle values of 0 for maxUnavailable and maxSurge 2020-12-09 21:03:09 UTC
Red Hat Product Errata RHBA-2020:5115 0 None None None 2020-11-30 16:45:51 UTC

Description OpenShift BugZilla Robot 2020-11-03 18:47:06 UTC
+++ This bug was initially created as a clone of Bug #1894110 +++

On the Deployment page, the console will show the value 1 if either maxUnavailable or maxSurge is set to 0. These fields are allowed to be set to 0 (as long as they're not both 0). We should only show the default value as 1 if the fields are missing from the resource YAML.

--- Additional comment from spadgett@redhat.com on 2020-11-03 18:04:11 UTC ---

*** Bug 1891820 has been marked as a duplicate of this bug. ***

--- Additional comment from spadgett@redhat.com on 2020-11-03 18:07:08 UTC ---

*** Bug 1891820 has been marked as a duplicate of this bug. ***

Comment 2 Yadan Pei 2020-11-13 05:51:44 UTC
Create a deployment, check values on Deployment details page:
when maxUnavailable is set to 0, Max Unavailable shows '0 of 2 pods'
When maxSurge is set to 0, Max Surge shows '0 greater than 2 pods'

For Deployment Config, fix for this bug should be good but we can't check the display due to bug https://bugzilla.redhat.com/show_bug.cgi?id=1897423

Moving this to VERIFIED since the original issue reported has been resolved

Verified on 4.6.0-0.nightly-2020-11-12-142005

Comment 5 errata-xmlrpc 2020-11-30 16:45:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5115


Note You need to log in before you can comment on or make changes to this bug.