Bug 1894483 - bash syntax error in nodeip-configuration.service
Summary: bash syntax error in nodeip-configuration.service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.z
Assignee: Antonio Murdaca
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On: 1894477
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-04 11:08 UTC by Tomáš Nožička
Modified: 2020-11-30 16:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1894477
Environment:
Last Closed: 2020-11-30 16:45:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 2200 0 None closed [release-4.6] Bug 1894483: Fix bash in nodeip-configuration.service 2020-11-24 15:09:21 UTC
Red Hat Product Errata RHBA-2020:5115 0 None None None 2020-11-30 16:45:51 UTC

Description Tomáš Nožička 2020-11-04 11:08:00 UTC
+++ This bug was initially created as a clone of Bug #1894477 +++

Description of problem:
nodeip-configuration.service contains invalid bash which borked OKD UPI cluster install.

Version-Release number of selected component (if applicable):
4.6.0-0.okd-2020-11-03-123207


How reproducible:
always


Steps to Reproduce:
1. install OKD with UPI
2.
3.

Actual results:
[root@master-0 ~]# systemctl status nodeip-configuration
● nodeip-configuration.service - Writes IP address configuration so that kubelet and crio services select a valid node IP
     Loaded: loaded (/etc/systemd/system/nodeip-configuration.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Wed 2020-11-04 08:22:50 UTC; 22min ago
    Process: 980 ExecStart=/bin/bash -c     until    /usr/bin/podman run --rm    --authfile /var/lib/kubelet/config.json    --net=host    --volume /etc/systemd/system:/etc/systemd/system:z    registry.svc.ci.openshift.org/origin/4.6-2020>
   Main PID: 980 (code=exited, status=1/FAILURE)
        CPU: 4ms
lis 04 08:22:50 master-0 systemd[1]: Starting Writes IP address configuration so that kubelet and crio services select a valid node IP...
lis 04 08:22:50 master-0 bash[980]: /bin/bash: -c: line 0: syntax error near unexpected token `done'
lis 04 08:22:50 master-0 bash[980]: /bin/bash: -c: line 0: `    until    /usr/bin/podman run --rm    --authfile /var/lib/kubelet/config.json    --net=host    --volume /etc/systemd/system:/etc/systemd/system:z    registry.svc.ci.openshift>
lis 04 08:22:50 master-0 systemd[1]: nodeip-configuration.service: Main process exited, code=exited, status=1/FAILURE
lis 04 08:22:50 master-0 systemd[1]: nodeip-configuration.service: Failed with result 'exit-code'.
lis 04 08:22:50 master-0 systemd[1]: Failed to start Writes IP address configuration so that kubelet and crio services select a valid node IP.


Expected results:
success

Additional info:

Comment 3 Michael Nguyen 2020-11-24 16:49:28 UTC
$ mco-commit registry.svc.ci.openshift.org/origin/release:4.6.0-0.okd-2020-11-24-050344
Name:        registry.svc.ci.openshift.org/origin/4.6-2020-11-24-050344@sha256:3d348d299bbbbd266961a789f157f28d9b3b15a0c2bc54278b30549ec47f33f1
Media Type:  application/vnd.docker.distribution.manifest.v2+json
Created:     4d ago
Image Size:  138.5MB in 6 layers
Layers:      73.96MB sha256:77c58f19bd6e67185938abb6bbb6ec229e07a5e607453904294d982de141d2f0
             1.718kB sha256:47db82df7f3f4393c1f19c362a2db2c47ca049b6fb20bef041dfc9bdb12a4504
             5.445MB sha256:9e518d0279d9c75999daa4b867d4924c26b32617223a7ff068027268dcdbf4e4
             454kB   sha256:bbc16fbcaa26c3f8439b5959ad8c8488df305ffd1d083441670dcf75f836ce70
             11MB    sha256:7cb8553f8ce2ece3392c535cb412dc894489c4f66412ce3ac346fd34e70d8b71
             47.65MB sha256:ef2068c916c7d1c2cc0b7a8c949319385a54a57cd5cf83ade862a57fb4e739e9
OS:          linux
Arch:        amd64
Entrypoint:  /usr/bin/machine-config-operator
User:        0
Environment: GODEBUG=x509ignoreCN=0
             OPENSHIFT_CI=true
             PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
             container=oci
             foo=bar
             OPENSHIFT_BUILD_NAME=machine-config-operator
             OPENSHIFT_BUILD_NAMESPACE=ci-op-zk8gi39y
Labels:      architecture=x86_64
             build-date=2020-09-05T01:13:15.933978
             com.redhat.build-host=cpt-1003.osbs.prod.upshift.rdu2.redhat.com
             com.redhat.component=openshift-enterprise-base-container
             com.redhat.license_terms=https://www.redhat.com/agreements
             description=The Universal Base Image is designed and engineered to be the base layer for all of your containerized applications, middleware and utilities. This base image is freely redistributable, but Red Hat only supports Red Hat technologies through subscriptions for Red Hat products. This image is maintained by Red Hat and updated regularly.
             distribution-scope=public
             io.buildah.version=1.16.4
             io.k8s.description=This is the base image from which all OpenShift images inherit.
             io.k8s.display-name=OpenShift Base
             io.openshift.build.commit.author=
             io.openshift.build.commit.date=
             io.openshift.build.commit.id=721141df0005d407d15b6664982f22be0604eb72
             io.openshift.build.commit.message=
             io.openshift.build.commit.ref=release-4.6
             io.openshift.build.name=
             io.openshift.build.namespace=
             io.openshift.build.source-context-dir=
             io.openshift.build.source-location=https://github.com/openshift/machine-config-operator
             io.openshift.expose-services=
             io.openshift.release.operator=true
             io.openshift.tags=base rhel8
             maintainer=Red Hat, Inc.
             name=openshift/ose-base
             release=202009050041.5133
             summary=Provides the latest release of Red Hat Universal Base Image 8.
             url=https://access.redhat.com/containers/#/registry.access.redhat.com/openshift/ose-base/images/v4.0-202009050041.5133
             vcs-ref=721141df0005d407d15b6664982f22be0604eb72
             vcs-type=git
             vcs-url=https://github.com/openshift/machine-config-operator
             vendor=Red Hat, Inc.
             version=v4.0

Verified registry.svc.ci.openshift.org/origin/release:4.6.0-0.okd-2020-11-24-050344 contains the commit with the nodeip-configuration.service script update.

Comment 5 errata-xmlrpc 2020-11-30 16:45:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5115


Note You need to log in before you can comment on or make changes to this bug.