Bug 189457 - MIxed x86_64/i386 update issues
MIxed x86_64/i386 update issues
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-20 01:46 EDT by Danny Ciarniello
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 11:28:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Danny Ciarniello 2006-04-20 01:46:36 EDT
Description of problem:
Cannot update components that have both x86_64 and i386 versions installed.  In
particular I have

librsvg2-2.14.2-1.x86_64
librsvg2-2.14.2-1.i386
libgnome-2.14.0-1.x86_64
libgnome-2.14.0-1.i386

installed.  Attempting to update these give errors such as:

  file /etc/gconf/schemas/desktop_gnome_lockdown.schemas from install of
libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.14.0-1


Version-Release number of selected component (if applicable):


How reproducible:Always


Steps to Reproduce:
1. Install x86_64 and i386 versions of libgnome from the core repository
2. execute yum update
3.
  
Actual results:
libgnome not updated but errors similar to that given above printed

Expected results:
libgnome updated without error

Additional info:
Comment 1 Jeremy Katz 2006-04-20 08:41:42 EDT
Where did you install libgnome.i386 from?  It doesn't seem to be in the main
x86_64 tree from my quick look.
Comment 2 Danny Ciarniello 2006-04-20 11:20:04 EDT
I originally installed libgnome.i386 by downloading the rpm from the main i386
tree (I need libgnome.i386 for firefox.i386) and installed it using rpm.  I have
since re-installed with yum after creating a repo file for the i386 tree.  The
installation can also be done using yumex by setting the "Force i386
architecture" on the Repos page.  

Note that the comments above also apply to librsvg2.i386 (the error is similar
to the example I gave for libgnome).
Comment 3 Jeremy Katz 2006-04-20 11:28:28 EDT
If you pull packages out of the i386 repo, you're also going to need to enable
the i386 updates repository.
Comment 4 Danny Ciarniello 2006-04-20 12:50:36 EDT
Thanks, that worked.

It should have been obvious that this was the solution but for some reason it
wasn't.  Maybe an explicit comment in the Multiarch section of the Release Notes
would be a good idea.
Comment 5 Danny Ciarniello 2006-04-20 13:06:50 EDT
Hmmm...

I've just taken a look at the x86_64 tree (both core and updates) and noticed
that some packages (e.g. arts and avahi) have both x86_64 and i386 versions in
the x86_64 tree while others (namely libgnome) do not.  This apparent
inconsistency makes things somewhat confusing.

Note You need to log in before you can comment on or make changes to this bug.