Bug 189458 - GUI virtual console shifts on logout
GUI virtual console shifts on logout
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-20 02:04 EDT by Danny Ciarniello
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 17:56:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Danny Ciarniello 2006-04-20 02:04:04 EDT
Description of problem:
Logging in and out of X causes the GUI virtual console to shift from the 7th to
8th to 9th, etc, consoles.  If a user logs in and out enough times, the GUI
console can be lost since there is no way to get back to it for the 13th and
beyond consoles.

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Log in and out of X
2. Ctl-Alt-F1 to go to the first virtual text console
3. Ctl-Alt-F7 to go back to GUI console -> blank screen
4. Ctl-Alt-F8 to go to X login screen
5. Log in and out again and note that GUI console shifts to Ctl-Alt-F9
  
Actual results:
GUI console shifts on login/logout

Expected results:
GUI console stays put


Additional info: I am using KDE as my desktop but I don't think that is the
cause of the problem
Comment 1 Mike A. Harris 2006-05-23 09:06:32 EDT
If you're logging out, and back in and getting a new tty allocated, this is
an indication that the previous tty is not getting released.  Please log out
a few times to reproduce this, and then attach the output of:

ps ax > ps.log

Also attach your X server log and config file as individual uncompressed file
attachments, using the link below.

Thanks in advance.
Comment 2 Danny Ciarniello 2006-07-18 01:24:38 EDT
This is no longer a problem.  It looks like it was fixed in one of the xorg updates.

Note You need to log in before you can comment on or make changes to this bug.