Bug 189459 - VFAT charset options have no effect
VFAT charset options have no effect
Status: CLOSED DUPLICATE of bug 183564
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-20 02:25 EDT by TOYAMA Shin-ichi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 08:37:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description TOYAMA Shin-ichi 2006-04-20 02:25:58 EDT
Description of problem:
Charset options for VFAT have no effect and filename always appears in UTF-8.

Version-Release number of selected component (if applicable):
2.6.16-1.2080

How reproducible:
Always

Steps to Reproduce:
1. # mount -t vfat -o codepage=932,iocharset=euc-jp /dev/xxx /mount/point
2. # ls /mount/point
  
Actual results:
Filenames in /mount/point appears in UTF-8

Expected results:
Filenames in /mount/point appears in euc-jp

Additional info:
There is no problem with vanilla kernel(2.6.16.9) from kernel.org
Comment 1 Kurt Swanson 2006-07-06 21:03:33 EDT
Apparently it was decided that all VFAT partitions SHALL be UTF8, unless
explicitly told otherwise, via an undocumented option.  For a work-around, mount
your VFAT partitions with an additional, undocumented option: utf8=0

See bug 181963

Note that other distros, like Ubuntu, do not have this hard-coded kernel bug.
Comment 2 TOYAMA Shin-ichi 2006-07-07 23:56:36 EDT
Adding option utf8=0 worked well, thank you!
But I feel it incorrect that kerel ignores iocharset option without this
work-around.
Comment 3 Dawid Gajownik 2006-07-13 08:37:29 EDT

*** This bug has been marked as a duplicate of 183564 ***

Note You need to log in before you can comment on or make changes to this bug.