Bug 189490 - "--recommended" swap partition is too small
"--recommended" swap partition is too small
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-20 10:27 EDT by Peter Fales
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 15:19:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full kickstart file (6.42 KB, text/plain)
2006-06-20 15:23 EDT, Peter Fales
no flags Details

  None (edit)
Description Peter Fales 2006-04-20 10:27:28 EDT
Description of problem:

My ks.cfg file contains 

    part swap --recommended

On two different systems (both with 128M memory), the kickstart fails about
halfway through and the system is left in an unbootable state.  The swap
partition is only 128M in size.  I believe that this is too small and the 
installer is running out of memory.  If I change it too:

    part swap --size 256 

then the install completes



Version-Release number of selected component (if applicable):


How reproducible:  Very


Steps to Reproduce:

1. Create ks.cfg file containing "part swap --recommended"
2. Begin kickstart

  
Actual results:  Systems reboots after completing roughly 60% of the install


Expected results:  Full install


Additional info:
Comment 1 Chris Lumens 2006-04-24 16:17:08 EDT
Please post your complete kickstart file so I can see what other
partition-related stuff you're doing.
Comment 2 Peter Fales 2006-06-20 15:23:30 EDT
Created attachment 131215 [details]
full kickstart file
Comment 3 Peter Fales 2006-06-20 15:24:55 EDT
Sorry for the delay - I don't recall ever being notified of the request though I
probably just missed it. 
Comment 4 Peter Fales 2006-10-09 15:16:09 EDT
For the record, I don't think the other partition related stuff is the problem
here.   I think the issue is that the machine I'm installing on only has 128M of
memory, and somehow the swap space calculation is deciding that only 128M of
swap is needed.  That's not enough to actually let the install complete.

Let me know if any other information/debugging is needed.
Comment 5 Chris Lumens 2006-10-12 15:19:31 EDT
The reason I was asking about your other partition information was because we
define minimum and maximum swap values for the swap partition and then grow this
partition's size if possible.  This grow procedure depends on what other
partitions you have and how large they are.  However, the best thing to do here
is to just tweak all the numbers that define what a low memory case is and what
ranges we use for that case.  This will be fixed in post-FC6 anaconda builds.

Just so you know, the minimum requirements for installation have crept up quite
a bit lately even for the text installs, so you are probably going to have a
harder time in the future of completing installations.  This is related to
memory pressure in the package dependancy resolution that we have not yet been
able to get to the bottom of.

Note You need to log in before you can comment on or make changes to this bug.