Bug 1894947 (CVE-2020-28032) - CVE-2020-28032 wordpress: hardening deserialization requests
Summary: CVE-2020-28032 wordpress: hardening deserialization requests
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2020-28032
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1894948 1894949
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-05 13:40 UTC by Guilherme de Almeida Suckevicz
Modified: 2020-11-05 14:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-05 14:21:15 UTC
Embargoed:


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2020-11-05 13:40:14 UTC
WordPress before 5.5.2 mishandles deserialization requests in wp-includes/Requests/Utility/FilteredIterator.php.

References:
https://wordpress.org/news/2020/10/wordpress-5-5-2-security-and-maintenance-release/
https://wpscan.com/vulnerability/10446

Upstream patch:
https://github.com/WordPress/wordpress-develop/commit/add6bedf3a53b647d0ebda2970057912d3cd79d3

Comment 1 Guilherme de Almeida Suckevicz 2020-11-05 13:40:34 UTC
Created wordpress tracking bugs for this issue:

Affects: epel-all [bug 1894949]
Affects: fedora-all [bug 1894948]

Comment 2 Product Security DevOps Team 2020-11-05 14:21:15 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.