Bug 18950 - up2date's "Packages Marked to be Skipped" is vague
up2date's "Packages Marked to be Skipped" is vague
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-12 07:38 EDT by David F. Elliott
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-12 07:38:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David F. Elliott 2000-10-12 07:38:46 EDT
The "Packages Marked to be Skipped" screen is somewhat vague.  At first
glance it seems that you are supposed to check the packages you want to
skip.  Then I read the text at the bottom saying "You may choose to
override your preferences and add some or all of these to the list of
packages to retrieve" which is quite vague about what actually happens if
you check/uncheck the box for a package.

Better text would be something like "According to your preferences you have
chosen not to automatically update the above packages.  If you would like
to include a package in the list of packages to retrieve, select its
checkbox."

That wording clearly states that if you check the box it will be included,
but if you leave it unchecked then it will not be included.

Furthermore, I would suggest not using the word "marked" in the title since
marked is sometimes synonymous with "checked" and that is where the
confusion starts in the first place.  However I am not exactly sure how to
word that without being too wordy, possibly just leave it as is but clarify
it at the bottom of the screen as I have suggested.

Another anomaly is that if you do select the package in this list, it only
adds it to the list of available updates so you have to select it again if
you really want it.  On the one hand, it gives the user another chance if
they were fooled by the vagueness of the first screen.  On the other hand
it seems somewhat stupid to have to tell the program "I want to download
this" "Yes, I meant it, I really do want to download it". However that is
probably good since you don't want people just haphazardly upgrading their
kernel without reconfiguring the bootloader.

Since the only packages in the default skip-packages list are kernel
related, then this bug won't show up until a new kernel package is
available. The reason it showed up on my system is that I have replaced the
kernel-headers package with my own headers package from 2.2.18pre15.  So if
you feel the need to provide an update kernel package it would be wise to
fix this small bug before doing so.

-Dave
P.S. VERY good move getting rid of the /usr/include/{asm,linux} symlinks
and replacing them with files copied out of a built kernel source. That is
by far one of the better ideas I have seen lately, among other great things
like the switch to xinetd to simplify configuration.  Keep up the good
work!
Comment 1 Preston Brown 2000-11-27 16:38:59 EST
Dave:  these are all good suggestions, and have been incorporated into an errata
release of update agent that will be available later this week.

Note You need to log in before you can comment on or make changes to this bug.