Bug 18951 - libGL does not work with R128
libGL does not work with R128
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-12 08:23 EDT by Daniel Thompson
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-17 12:55:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Thompson 2000-10-12 08:23:35 EDT
On my machine OpenGL does not work correctly. xscreensavers all work
correctly. battailion (powertools) works correctly in low detail but
becomes whited out in high detail mode. Likewise tuxracer and xracer do not
render correctly.

Following instructions at dri.sourceforge.net I got a CVS snapshot of the
Xserver. Part of the install of the CVS snapshot removed libGL.so &
libGL.so.? from /usr/lib and replaces it with its own. Replacing libGL is
sufficient to solve the problems outlined above (the Xserver does not
overwrite the default RH7.0 one since I modified the config).

My hardware is a 300Mhz K6 super-socket 7 (VIA VP3) and a 16MB AGP Rage 128.
Comment 1 Bernhard Rosenkraenzer 2000-10-12 09:31:54 EDT
I don't have the hardware to verify this. Please check if the version found at
http://www.linux-easy.com/rh-updates/ fixes this.
Comment 2 Daniel Thompson 2000-10-15 05:41:57 EDT
Sorry ladies and gentlemen, Meaa-3.3-7 (from linux-easy) does not make any
difference.
Comment 3 Bernhard Rosenkraenzer 2000-10-17 05:11:59 EDT
Looks like an XFree86 problem then (On systems with DRI, Mesa doesn't do
anything but pipe through the requests), reassigning.
Comment 4 Bernhard Rosenkraenzer 2001-02-17 12:55:04 EST
Does this work in the current versions (XFree86 4.0.2-9, Mesa 3.4-8)?
Comment 5 Mike A. Harris 2001-02-26 17:19:29 EST
GL works fine for me on all r128 based cards I have here using the latest
Rawhide.  Hardware accelerated in Wolverine + Rawhide XFree (-10 release).

Note You need to log in before you can comment on or make changes to this bug.