Bug 189519 - Unable to set the ConnFailTimeout value for the driver
Unable to set the ConnFailTimeout value for the driver
Status: CLOSED DUPLICATE of bug 189512
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-20 14:06 EDT by Wayne Berthiaume
Modified: 2008-04-07 01:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 14:37:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Syslog snipet of 10 second cable pull failure (62.68 KB, text/plain)
2006-04-20 14:06 EDT, Wayne Berthiaume
no flags Details

  None (edit)
Description Wayne Berthiaume 2006-04-20 14:06:39 EDT
Description of problem:
EMC PowerPath reports DEAD paths during 10 second cable pulls when 
ConnFailTimeout has been set to 30 in /etc/iscsi.conf. If you 
cat /sys/class/scsi_host/hostX/connfail_timeout it is always 5.

Version-Release number of selected component (if applicable):
4:0.1.11-2

How reproducible:
always

Steps to Reproduce:
1. set ConnFailTimeout to 30 in /etc/iscsi.conf
2. service iscsi restart
3. perform 10 second cable pulls
  
Actual results:
EMC PowerPath marks the paths as DEAD and tresspasses the LUNs

Expected results:
iscsi_sfnet should log the session failure but not but the path failure to EMC 
PowerPAth until after the 30 timer has expired. The result would be that EMC 
PowerPath does not mark the path as DEAD or perform the tresspass until after 
the 30 second timer has expired.

Additional info:
See attached syslog snipet of 10 second cable pull and path failures with 
ConnFailTimeout set to 30

Also, service iscsi debug no longer works so I am unable to provide driver 
debug information.The daemon and driver start; however, the driver fails to 
initialize and scan the bus.
Comment 1 Wayne Berthiaume 2006-04-20 14:06:39 EDT
Created attachment 128050 [details]
Syslog snipet of 10 second cable pull failure
Comment 2 Andrius Benokraitis 2006-04-20 14:37:52 EDT

*** This bug has been marked as a duplicate of 189512 ***

Note You need to log in before you can comment on or make changes to this bug.