Bug 1895372 - Web console going blank after selecting any operator to install from OperatorHub
Summary: Web console going blank after selecting any operator to install from OperatorHub
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.7.0
Assignee: Samuel Padgett
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On:
Blocks: 1896600
TreeView+ depends on / blocked
 
Reported: 2020-11-06 14:17 UTC by ychoukse
Modified: 2021-02-24 15:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, an OperatorGroup with a missing `status` block in any namespace could cause a runtime error in the web console when installing a new operator from OperatorHub. The problem has been fixed.
Clone Of:
Environment:
Last Closed: 2021-02-24 15:31:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
Console pod logs (49.71 KB, text/plain)
2020-11-09 17:44 UTC, ychoukse
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 7172 0 None closed Bug 1895372: Tolerate missing `status` on OperatorGroups 2021-02-08 18:56:24 UTC
Red Hat Knowledge Base (Solution) 5581141 0 None None None 2020-11-28 16:43:03 UTC
Red Hat Product Errata RHSA-2020:5633 0 None None None 2021-02-24 15:32:00 UTC

Description ychoukse 2020-11-06 14:17:15 UTC
Description of problem:
Operator hub is showing blank screen after selecting any operator to install. 
Gif: https://attachment-viewer.cee.redhat.com/#/viewer/02769012?uuid=ed1dbd5f-85e6-498a-b583-24c820efbcba 

Issue occurs with all the operators, irrespective of their provider type.
The cluster has all packagemanifests, opsrc and catsrc present. 


Version-Release number of selected component (if applicable):
Baremetal, connected installation. Cluster version is at 4.5.16 (issue occurs on similar cluster at version 4.5.14)

How reproducible:
Always

Steps to Reproduce:
1. Login the Web console as the cluster-admin user(or any user).
OCP web-console -> Operator Hub -> Select any operator (Click install) ->  Blank white screen


Actual results:
The page jumps in the blank status, and cannot recover after clicking the back button. URL redirection doesn't work, a new window needs to be opened for console.

Expected results:
I know something is wrong with the operator hub(maybe), but we should pop-up errors instead of the blank page.


Additional info:
Nothing suspicious in marketplace pods, or any other related pods, all are in running state.
However, the openshift-console shows logs:

2020-11-05T16:10:02Z server: authentication failed: http: named cookie not present
2020-11-05T16:10:04Z server: authentication failed: http: named cookie not present

Restarting console pods didn't help.

Comment 2 Robb Hamilton 2020-11-09 16:28:40 UTC
Jakub Hadvig tried and failed to reproduce on a fresh 4.5.16 cluster.  I tried and failed to reproduce using Firefox 82.0.3 for macOS 10.15.7, namespace 'gitlab-runner', and operator 'gitlab' on a fresh 4.5.14 cluster. Are there any browser console errors present when the error occurs?

Comment 4 ychoukse 2020-11-09 17:44:24 UTC
Created attachment 1727892 [details]
Console pod logs

Comment 5 Robb Hamilton 2020-11-09 19:23:46 UTC
> However, we didn't see any errors on the developer console while replicating the issue on Cu's env. 

Did you mean the web console (e.g., https://developer.mozilla.org/en-US/docs/Tools/Web_Console)?

Typically when the entire browser window goes white (empty), that means the entire OpenShift web console app has crashed, and I would expect to see one or more errors in the web console.

Comment 7 Samuel Padgett 2020-11-10 15:12:42 UTC
We've been able to reproduce. This is happening because one of the OperatorGroup resources doesn't have a `status` stanza, which causes a runtime error in console.

Uncaught TypeError: og.status is undefined

Comment 9 Samuel Padgett 2020-11-10 15:40:17 UTC
We're working on a fix, but you should be able to workaround this problem in the meantime by adding editing any OperatorGroup without a `status` and adding `status: {}` to the YAML.

Comment 10 Samuel Padgett 2020-11-10 15:43:56 UTC
(In reply to Samuel Padgett from comment #9)
> We're working on a fix, but you should be able to workaround this problem in
> the meantime by adding editing any OperatorGroup without a `status` and
> adding `status: {}` to the YAML.

Actually it probably has to be

status:
  namespaces: []

Comment 14 Yanping Zhang 2020-11-11 11:37:51 UTC
Checked on ocp 4.7 cluster with payload 4.7.0-0.nightly-2020-11-11-055454, create operatorgroup with file in attachment. Then go to operatorhub page, choose an operator, click "Install", the page shows up correctly, it's not blank now.
The bug is fixed.

Comment 21 errata-xmlrpc 2021-02-24 15:31:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.7.0 security, bug fix, and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2020:5633


Note You need to log in before you can comment on or make changes to this bug.