Bug 189551 - Network proxy preferences not seen by pirut
Network proxy preferences not seen by pirut
Status: CLOSED DUPLICATE of bug 185309
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-20 19:07 EDT by Steve Baker
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 19:27:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Baker 2006-04-20 19:07:24 EDT
Description of problem:
Not obvious how to set up pirut to work through a proxy when launched from gnome.

Version-Release number of selected component (if applicable):
pirut --version doesn't work. It is the version that came with FC5 #1.

How reproducible:
Try running in an environment that has a proxy firewall.



Steps to Reproduce:
1. Set up environment for working with a proxy/firewall by setting network proxy
preferences (System Menu -> Preferences -> Network Proxy).  In my case, I use
manual proxy configuration.
2. Run pirut from gnome graphical environment as root (Applications menu
->Add/Remove Software)
3.
  
Actual results:
Hangs for a minute or two, times out with an error dialog, then exits when the
error is acknowledged.

Expected results:
1) Setting up network proxy preferences (System Menu -> Preferences -> Network
Proxy)should be all that is needed to configure a proxy environment for all
networking applications launched from the graphical environment.

Additional info:

It appears that pirut expects to inherit proxy settings from the environment
that launches it and does not go looking in conf files that the network proxy
application sets. The window manager apparently does not provide these settings
in the environment when it spawns an application.  This may really be an issue
with the window manager and not pirut.

The following flailing attempts were tried and do not seem to work:

1) Set up the network proxy preferences (System Menu -> Preferences -> Network
Proxy). Even tried logging out and back in and tried rebooting - both with no joy.
2) Added a proxy statement to yum.conf (proxy=http://foo.bar.com:1234).
3) Added the following lines to /etc/wgetrc:
  http_proxy=http://host.com:port/
  ftp_proxy=http://host.com:port/
4) Created files proxy.sh and proxy.csh in /etc/proxy.d and populated as follows:
  #proxy.sh
  export http_proxy=http://host.com:port/
  export ftp_proxy=http://host.com:port/
  export no_proxy=.domain.com
  export HTTP_PROXY=http://host.com:port/
  export FTP_PROXY=http://host.com:port/

  #proxy.csh
  setenv http_proxy http://host.com:port/
  setenv ftp_proxy http://host.com:port/
  setenv no_proxy .domain.com
  setenv HTTP_PROXY http://host.com:port/
  setenv FTP_PROXY http://host.com:port/

Note 1: While this has no discernable effect when pruit is launched from Gnome
(Applications menu ->Add/Remove Software), it does affect shell environments as
would be expected.

Note 2: If pirut is launched manually from one of these shell environments then
it *does* work.
Comment 1 Jeremy Katz 2006-04-20 19:27:55 EDT

*** This bug has been marked as a duplicate of 185309 ***

Note You need to log in before you can comment on or make changes to this bug.