Bug 1895623 - Can't start appliance because of epoch:version-release
Summary: Can't start appliance because of epoch:version-release
Keywords:
Status: CLOSED DUPLICATE of bug 1858625
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-07 20:29 UTC by CL
Modified: 2020-11-09 08:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-09 08:57:30 UTC


Attachments (Terms of Use)

Description CL 2020-11-07 20:29:56 UTC
Description of problem:

When I start a VM I get the following error message: "Error launching libguestfs appliance: /usr/bin/supermin"
Then when I run: libguestfs-test-tool  it gives me: supermin: failure: failed to parse epoch:version-release field 2.04-11.1


Version-Release number of selected component (if applicable):
libguestfs: launch: program=libguestfs-test-tool
libguestfs: launch: version=1.42.0


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Running virt-manager to manage qemu virtual machines on Manjaro Linux (kernel 5.9)

Output for libguestfs-test-tool:

PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl
XDG_RUNTIME_DIR=/run/user/1000
SELinux: sh: getenforce: Kommando nicht gefunden.
guestfs_get_append: (null)
guestfs_get_autosync: 1
guestfs_get_backend: direct
guestfs_get_backend_settings: []
guestfs_get_cachedir: /var/tmp
guestfs_get_hv: /usr/bin/qemu-system-x86_64
guestfs_get_memsize: 768
guestfs_get_network: 0
guestfs_get_path: /usr/lib/guestfs
guestfs_get_pgroup: 0
guestfs_get_program: libguestfs-test-tool
guestfs_get_recovery_proc: 1
guestfs_get_smp: 1
guestfs_get_sockdir: /run/user/1000
guestfs_get_tmpdir: /tmp
guestfs_get_trace: 0
guestfs_get_verbose: 1
host_cpu: x86_64
Launching appliance, timeout set to 600 seconds.
libguestfs: launch: program=libguestfs-test-tool
libguestfs: launch: version=1.42.0
libguestfs: launch: backend registered: unix
libguestfs: launch: backend registered: uml
libguestfs: launch: backend registered: libvirt
libguestfs: launch: backend registered: direct
libguestfs: launch: backend=direct
libguestfs: launch: tmpdir=/tmp/libguestfsratTkg
libguestfs: launch: umask=0022
libguestfs: launch: euid=1000
libguestfs: begin building supermin appliance
libguestfs: run supermin
libguestfs: command: run: /usr/bin/supermin
libguestfs: command: run: \ --build
libguestfs: command: run: \ --verbose
libguestfs: command: run: \ --if-newer
libguestfs: command: run: \ --lock /var/tmp/.guestfs-1000/lock
libguestfs: command: run: \ --copy-kernel
libguestfs: command: run: \ -f ext2
libguestfs: command: run: \ --host-cpu x86_64
libguestfs: command: run: \ /usr/lib/guestfs/supermin.d
libguestfs: command: run: \ -o /var/tmp/.guestfs-1000/appliance.d
supermin: version: 5.2.0
supermin: package handler: arch/pacman
supermin: acquiring lock on /var/tmp/.guestfs-1000/lock
supermin: build: /usr/lib/guestfs/supermin.d
supermin: reading the supermin appliance
supermin: build: visiting /usr/lib/guestfs/supermin.d/base.tar.gz type gzip base image (tar)
supermin: build: visiting /usr/lib/guestfs/supermin.d/daemon.tar.gz type gzip base image (tar)
supermin: build: visiting /usr/lib/guestfs/supermin.d/excludefiles type uncompressed excludefiles
supermin: build: visiting /usr/lib/guestfs/supermin.d/hostfiles type uncompressed hostfiles
supermin: build: visiting /usr/lib/guestfs/supermin.d/init.tar.gz type gzip base image (tar)
supermin: build: visiting /usr/lib/guestfs/supermin.d/packages type uncompressed packages
supermin: build: visiting /usr/lib/guestfs/supermin.d/udev-rules.tar.gz type gzip base image (tar)
supermin: mapping package names to installed packages
supermin: failure: failed to parse epoch:version-release field 2.04-11.1
libguestfs: Fehler: /usr/bin/supermin beendet mit Fehlerstatus 1, see debug messages above
libguestfs: closing guestfs handle 0x557a42e072c0 (state 0)
libguestfs: command: run: rm
libguestfs: command: run: \ -rf /tmp/libguestfsratTkg

Comment 1 Richard W.M. Jones 2020-11-07 22:03:11 UTC
What Linux distro is this?  What exact version is installed and where is it from?

Comment 2 CL 2020-11-08 06:15:03 UTC
Linux manjaro 5.9.3-1-MANJARO #1 SMP PREEMPT Sun Nov 1 14:25:36 UTC 2020 x86_64 GNU/Linux (based on Arch Linux)

libguestfs was installed from the official distro repostitories

libguestfs-test-tools and the repo information tells me, that version 1.42.0 is installed (see my post above with the output of libguestfs-test-tools )

Comment 3 Richard W.M. Jones 2020-11-09 08:57:30 UTC
You need to add the following patch to supermin:
https://github.com/libguestfs/supermin/commit/1b6802ba85898c947f2276c365bf8be7eb5f1642

*** This bug has been marked as a duplicate of bug 1858625 ***


Note You need to log in before you can comment on or make changes to this bug.