Bug 189567 - i8kutils depends on tcl but yum didn't install it
i8kutils depends on tcl but yum didn't install it
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: i8kutils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 00:40 EDT by Elijah Newren
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.25-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 13:29:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elijah Newren 2006-04-21 00:40:09 EDT
Description of problem:
I did a barebones installation due to constant freezes/lockups on my stupid Dell
Inspiron 8100 laptop (which I believe are due to overheating, as the fans never
turn on during installation).  Anyway, first package I installed with yum was
i8kutils, which pulled down a few dependencies -- but not tcl.  I was unable to
run i8kmon, because i8kmon requires tcl to be installed.

Version-Release number of selected component (if applicable):
i8kutils-1.25-6.fc5

Steps to Reproduce:
1. Do a very minimal install, not including tcl
2. yum install i8kutils
3. i8kmon --daemon &
  
Actual results:
Get an error about tcl or tclsh being an unknown file/executable or whatever.

Expected results:
tcl gets installed as part of the yum command and everything works great

Additional info:
I'm assuming this is just a forgotten requires in the .spec file.  Kick me if
that's a bad assumption and this should be filed elsewhere.
Comment 1 Matthias Saou 2006-04-21 10:26:33 EDT
Indeed, the tcl requirement was still missing, even after the recent addition of
the tk requirement. This is fixed in CVS, so expect new packages to appear
anytime soon (once the build system is available again, it's undergoing
maintenance right now).
Comment 2 Matthias Saou 2006-04-21 13:29:34 EDT
New packages are built and should be pushed out shortly. Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.