Bug 189568 - Specifying -n tcp to fuser results in extraneous here:xx output
Specifying -n tcp to fuser results in extraneous here:xx output
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: psmisc (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 00:54 EDT by Steve Bergman
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 15:49:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to remove what looks like left over debugging code (353 bytes, patch)
2006-04-21 01:39 EDT, Steve Bergman
no flags Details | Diff

  None (edit)
Description Steve Bergman 2006-04-21 00:54:56 EDT
Description of problem:

Specifying a namespace of tcp or udp to fuser triggers extraneous output.

Version-Release number of selected component (if applicable):

psmisc-21.4-4

How reproducible:

Always


Steps to Reproduce:
1.fuser -n tcp 22
  
Actual results:

here: 22
22/tcp:               2916


Expected results:

22/tcp:               2916

Additional info:
Comment 1 Steve Bergman 2006-04-21 01:39:05 EDT
Created attachment 128074 [details]
Patch to remove what looks like left over debugging code
Comment 3 RHEL Product and Program Management 2006-09-05 15:39:03 EDT
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.
Comment 4 RHEL Product and Program Management 2006-09-05 15:49:22 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 
Comment 5 Steve Bergman 2006-09-05 16:40:37 EDT
In my opinion, this is a *clear* bug to which a *trivial* patch has been
submitted to fix.  This is confusing to admins who are expecting either a group
of numbers or nothing... and what they get is something like "here:22".

It also affects scripts that expect correct output from fuser.

This really should be fixed and the fix is trivial.

Thank you for your (re)consideration.

BTW, Bugzilla will not allow me to "appeal this decision by reopening this
request" for some reason.  It says I'm not the owner. 


Note You need to log in before you can comment on or make changes to this bug.