Bug 189582 - Warning message won't go away
Warning message won't go away
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On: 191536
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 08:09 EDT by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: libswt3-gtk2-3.1.2-1jpp_15fc
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 12:15:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug log from a couple of days of using azureus (7.92 KB, text/plain)
2006-04-21 08:09 EDT, Brian G. Anderson
no flags Details
Test case (895 bytes, text/plain)
2006-05-12 14:49 EDT, Anthony Green
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 142861 None None None Never

  None (edit)
Description Brian G. Anderson 2006-04-21 08:09:03 EDT
Description of problem:
I start azureus automatically as part of my gnome-session and have it minimize
to the system tray.  There are two problems that arise:

1) After logging out of gnome, whenever I relogin the next start of Azureus will
throw a warning message up about Azureus not having been shutdown tidily.  It
tells me to check ~/.azureus/logs which I will attach.  If I had exited azureus
before logging out, I would not get this message

2) Lately when this message comes up,  I can't make it go away unless I exit
azureus.  I can click the "hide" button, but the message stays.  Azureus works
fine, but the message will not go away and furthermore always stays on top of
other windows.


Version-Release number of selected component (if applicable):
azureus-2.4.0.3-0.20060328cvs_4.fc5


How reproducible:
on every login


Steps to Reproduce:
1. start azureus under gnome
2. logout from gnome without exiting azureus first
3. relogin to gnome and start azureus
4. try and "hide" the message
  
Actual results:
warning message displayed that cannot be removed


Expected results:
Azureus should not show this warning message and if it must it should allow me
to remove it.


Additional info:
Comment 1 Brian G. Anderson 2006-04-21 08:09:03 EDT
Created attachment 128080 [details]
Debug log from a couple of days of using azureus
Comment 2 Anthony Green 2006-04-21 08:34:12 EDT
(In reply to comment #0)
> 1) After logging out of gnome, whenever I relogin the next start of Azureus will
> throw a warning message up about Azureus not having been shutdown tidily.  It
> tells me to check ~/.azureus/logs which I will attach.  If I had exited azureus
> before logging out, I would not get this message

It's possible this is due to bugzilla #187686.  This has been fixed and we're
just waiting for a libgcj update.

> 2) Lately when this message comes up,  I can't make it go away unless I exit
> azureus.  I can click the "hide" button, but the message stays.  Azureus works
> fine, but the message will not go away and furthermore always stays on top of
> other windows.

Interesting!

Thanks for the bug report.  I'll try to reproduce these problems.

Comment 3 Anthony Green 2006-04-21 08:37:45 EDT
(In reply to comment #1)
> Created an attachment (id=128080) [edit]
> Debug log from a couple of days of using azureus

This log file indicates that you're running with both java-gcj-compat and Sun
java.  Do these problems show up with both VMs?  We need to eliminate that variable.
Comment 4 Brian G. Anderson 2006-04-21 13:42:05 EDT
I tried azureus using both VMs.  They both exhibit the exact same behavior with
respect to the message appearing and with it not being responsive to the "hide"
button.
Comment 5 Anthony Green 2006-04-21 14:04:21 EDT
(In reply to comment #4)
> I tried azureus using both VMs.  They both exhibit the exact same behavior with
> respect to the message appearing and with it not being responsive to the "hide"
> button.

Ok, thanks.  I was able to reproduce this with java-gcj-compat.  It's the first
time I've ever seen it.
Comment 6 Anthony Green 2006-04-24 17:38:53 EDT
One of the azureus hackers tells me that this is fixed in azureus cvs.  I
haven't looked for the fix yet.
Comment 7 Gilboa Davara 2006-04-25 08:35:35 EDT
Fully reproducible under KDE/x86_64/java-gcj-compat.

[gilboa@gilboa-work-dev ~]$ rpm -qa | grep gcj
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_83rh.x86_64
libgcj-4.1.0-3.i386
libgcj-4.1.0-3.x86_64
java-1.4.2-gcj-compat-1.4.2.0-40jpp_83rh.x86_64
java-1.4.2-gcj-compat-javadoc-1.4.2.0-40jpp_83rh.x86_64
libgcj-devel-4.1.0-3.x86_64

[gilboa@gilboa-work-dev ~]$ rpm -qa azureus
azureus-2.4.0.3-0.20060328cvs_4.fc5.x86_64
Comment 8 Anthony Green 2006-05-06 12:08:32 EDT
This is definitely an upstream problem.  Unforuntately sourceforge.net has been
broken for the past few weeks (anonymous cvs repositories aren't getting
updated).  So, for now, I have no access to the upstream fix (if one really does
exist).  Hopefully sourceforge.net will get their act together soon.

Comment 9 Anthony Green 2006-05-12 13:13:40 EDT
sourceforge.net is finally fixed.  I've testing the latest azureus code and the
problem persists.  Then I inserted some debugging code to print something when
the button gets pressed, and we're not getting any output.

At this point I suspect a problem with SWT.  I've CC'd overholt and will try to
create a reproducer.

Andrew - did SWT get updated in FC5 since the FC5 release?  Or gtk+?  If so, I
can try to revert to older versions and see what happens.


Comment 10 Anthony Green 2006-05-12 14:49:22 EDT
Created attachment 128950 [details]
Test case
Comment 11 Anthony Green 2006-05-12 14:51:18 EDT
I've attached a test case to this bug report.  It's a simple SWT example with a
button.  I'm no SWT expert. Is it supposed to work? I'm not getting any console
output when I press the button.
Comment 12 Anthony Green 2006-05-12 15:06:48 EDT
It turns out that the button isn't pressable if you create the shell in my
example with SWT.ON_TOP.  It works fine without SWT.ON_TOP.  But we want
SWT.ON_TOP...
Comment 13 Anthony Green 2006-05-12 15:24:21 EDT
Something is definitely going on in SWT-land.  I found the following example 
code that creates an SWT.ON_TOP window with a close button, and the button
doesn't work here either:

http://www.java2s.com/Code/Java/SWT-JFace-Eclipse/SWTShellcreateanonrectangularwindow.htm

I removed the swt .jar.so file, just to be sure it wasn't a gcj miscompilation
bug, and was still able to reproduce the problem.

I'll file a bug against libswt3-gtk2.
Comment 14 Anthony Green 2006-05-19 14:09:48 EDT
Rolling gtk2 back to gtk2-2.8.15-1 solves this problem.  
Comment 15 Anthony Green 2006-06-01 12:15:28 EDT
This is fixed in libswt3-gtk2-3.1.2-1jpp_15fc.

Note You need to log in before you can comment on or make changes to this bug.