This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 18960 - ncftpput, ncftpget remote cd fails
ncftpput, ncftpget remote cd fails
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: ncftp (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-12 10:04 EDT by Robert J. Osborne
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-12 10:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert J. Osborne 2000-10-12 10:04:43 EDT
The ncftpput and ncftpget do not properly change directory remotely. 
Instead, they report that the directory on the FTP server does not exist.
Comment 1 Bernhard Rosenkraenzer 2000-10-12 10:39:16 EDT
Both

"ncftpget ftp://ftp.linux-easy.com/pub/linux-easy/i386/lilo-config-0.1.0-1.i386.rpm"

and
"ncftpget ftp.linux-easy.com . /pub/linux-easy/i386/lilo-config-0.1.0-1.i386.rpm"

work for me.

This may be a problem with a specific server you're trying to access; feel free to reopen this bug with a test case.
Comment 2 Mike Gleason 2000-10-18 23:56:47 EDT
There was a bug, when the remote directory to use was an absolute path and the 
remote home directory was not root (i.e. any non-anonymous user).  The problem 
was that NcFTP was stripping the first slash, and treating the rest of the path 
as a relative path.  For example:

    ncftpget -u joeuser 10.1.2.3 /tmp /usr/bin/X11/xxgdb

This would fail with 3.0.1, because NcFTP would try to change to usr/bin/X11 
from the user's home directory.

NcFTP 3.0.2 will fix this problem.  (To be released October 19, 2000)

Mike Gleason

Note You need to log in before you can comment on or make changes to this bug.