Bug 189601 - XEN-Kernel crashes when try start on a i2o block device (Promise Fasttrack SX6000)
XEN-Kernel crashes when try start on a i2o block device (Promise Fasttrack SX...
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks: 179629
  Show dependency treegraph
 
Reported: 2006-04-21 11:03 EDT by Roland Kaeser
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-21 14:45:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Kaeser 2006-04-21 11:03:40 EDT
Description of problem:
Installed  FC5 on a P4/HT / Promise FastTrack SX6000 (Raid5).
Upgraded to xen (2096 kernel)
When restarting every time the i2o module loads (while startup) it crashes the
system and immediately reboots it.


Version-Release number of selected component (if applicable):
XEN-Kernel 2.6.15-1 2096

How reproducible:


Steps to Reproduce:
1. Install FC5 on P4(HT)/Asus/2GB RAM/Promise FastTrack SX6000 BIOS 1.1.xxx)
2. Yum install xen, xen-kernel etc.
3. Restart the system
  
Actual results:
Crashes while starting and automaticly reboots 

Expected results:
Normal startup

Additional info:
Is there some kind of redhat specific kernel boot parameter which prevents the
kernel immediately to reboot to see the exact reason?
Comment 1 Roland Kaeser 2006-04-21 12:10:26 EDT
Tried all sense making kernel options such as apci=off noapic molapic nosmp
pci=nobios,noacpi,nommconf,nosort,routeirq (panic=20) (nofb to be sure that the
problem is not framebuffer related) but no success. 

The Promise BIOS rev. is 1.10.000
Comment 2 Elson, Del 2006-05-06 03:13:41 EDT
Same result on a HP Proliant DL380 G3 booting from a cciss RAID 5 controller.

Going back to VMWare server now I think.  :)
Comment 3 Stephen Tweedie 2007-03-16 11:08:25 EDT
Is this still reproducible on the latest stable release+updates?  Thanks.
Comment 4 Elson, Del 2007-03-18 06:58:02 EDT
I have abandoned Xen in favour of VMWare so I won't be testing this.

Perhaps someone at Red Hat or HP can try some testing.

Note You need to log in before you can comment on or make changes to this bug.