Bug 1896129 - clustershell fails to build on Fedora 33+: Uses unversioned Python macros
Summary: clustershell fails to build on Fedora 33+: Uses unversioned Python macros
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: clustershell
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephane Thiell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F33FTBFS F34FTBFS PYTHON3.10 1857836
TreeView+ depends on / blocked
 
Reported: 2020-11-09 19:14 UTC by Miro Hrončok
Modified: 2020-12-01 01:27 UTC (History)
1 user (show)

Fixed In Version: clustershell-1.8.3-5.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-01 01:27:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-11-09 19:14:52 UTC
clustershell fails to build on Fedora 33+

rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=55256957
f33: https://koji.fedoraproject.org/koji/taskinfo?taskID=55256959

error: attempt to use unversioned python, define %__python to /usr/bin/python2 or /usr/bin/python3 explicitly
error: /builddir/build/SPECS/clustershell.spec: line 1: Macro %python_sitelib failed to expand

This is caused by the unversioned python macros on top of the spec file:

%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}

and

%{!?__python: %global __python python}


See https://fedoraproject.org/wiki/Changes/PythonMacroError

Comment 1 Miro Hrončok 2020-11-09 19:51:51 UTC
BTW I can remove the macros for you, but the spec looks like it is targeting many different distributions, so I's rather have your permission.

Comment 2 Fedora Release Engineering 2020-11-15 04:37:36 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 33.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-01-04).

A week before the mass branching of Fedora 34 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 32 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-34/f-34-key-tasks.html

Comment 3 Stephane Thiell 2020-11-22 02:07:32 UTC
Hi Miro,

Thanks for letting me know. I'm working on it now.

Comment 4 Fedora Update System 2020-11-22 06:36:45 UTC
FEDORA-2020-93f5d8ee0c has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-93f5d8ee0c

Comment 5 Miro Hrončok 2020-11-22 11:16:04 UTC
Thanks for the fix.

Comment 6 Fedora Update System 2020-11-23 02:01:12 UTC
FEDORA-2020-93f5d8ee0c has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-93f5d8ee0c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-93f5d8ee0c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-12-01 01:27:31 UTC
FEDORA-2020-93f5d8ee0c has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.