Bug 1896196 - In copr buildroot, file conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
Summary: In copr buildroot, file conflicts between attempted installs of texlive-tetex...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive-base
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-10 00:00 UTC by Bill Crawford
Modified: 2020-11-22 07:57 UTC (History)
5 users (show)

Fixed In Version: texlive-base-20200327-18.fc33 texlive-base-20200327-18.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-17 01:35:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Bill Crawford 2020-11-10 00:00:01 UTC
Description of problem:
File conflict when trying to install 'tex(latex)' as a BuildRequires: in a COPR build root (F32).

Version-Release number of selected component (if applicable):
20200327-16.fc32

How reproducible:
Try to build any R package in copr -- see recent build failures at https://copr.fedorainfracloud.org/coprs/willc/r-packages/builds/

Steps to Reproduce:
1. Submit .spec using copr-build
2. Wait eagerly / with bated breath / etc.
3. Experience disappointment.

Actual results:
Running transaction check
Transaction check succeeded.
Running transaction test
Error: Transaction test error:
  file /etc/texlive/web2c/updmap.cfg conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/man/man1/fmtutil.1.gz conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/man/man1/updmap.1.gz conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/fmtutil-user.sh conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/fmtutil.pl conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/updmap-user.sh conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/updmap.pl conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch


Copr build error: Build failed

Expected results:
...
INFO: Results and/or logs in: /var/lib/copr-rpmbuild/results
INFO: Cleaning up build root ('cleanup_on_success=True')
Start: clean chroot
INFO: unmounting tmpfs.
Finish: clean chroot
Finish: run

Additional info:
It's quite possible this is actually a dnf bug or an issue with the options used to install the build dependencies on the build workers ... please feel free to re-assign if so.

Comment 1 Bill Crawford 2020-11-10 22:15:02 UTC
Adding "texlive-obsolete" to the build root appears to work around the problem, for at least one package ...

Comment 2 Fedora Update System 2020-11-11 19:21:35 UTC
FEDORA-2020-fb18e81c97 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-fb18e81c97

Comment 3 Fedora Update System 2020-11-11 19:21:38 UTC
FEDORA-2020-903bc82607 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-903bc82607

Comment 4 Bill Crawford 2020-11-11 21:02:16 UTC
Thanks!

Is there any way to test this in copr? Can I add updates-testing? I'll, er, go try it ...

Comment 5 Tom "spot" Callaway 2020-11-11 21:15:59 UTC
One would think, but I don't know. Note that this update hasn't been pushed to testing yet.

Comment 6 Bill Crawford 2020-11-11 21:29:59 UTC
Ah :o)

Which package has the obsoletes logic on it? I think I could just put a koji URL for it in the "additional packages" box.

It's not that urgent though(!)

Comment 7 Tom "spot" Callaway 2020-11-11 22:43:25 UTC
texlive-texlive-scripts.

Comment 8 Fedora Update System 2020-11-12 04:26:17 UTC
FEDORA-2020-fb18e81c97 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-fb18e81c97`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-fb18e81c97

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2020-11-12 04:43:04 UTC
FEDORA-2020-903bc82607 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-903bc82607`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-903bc82607

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Bill Crawford 2020-11-12 11:36:43 UTC
Thanks again, have added karma.

Comment 11 Fedora Update System 2020-11-12 17:38:40 UTC
FEDORA-2020-903bc82607 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-903bc82607

Comment 12 Fedora Update System 2020-11-12 17:39:01 UTC
FEDORA-2020-fb18e81c97 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-fb18e81c97

Comment 13 Fedora Update System 2020-11-13 01:47:28 UTC
FEDORA-2020-903bc82607 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-903bc82607`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-903bc82607

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2020-11-13 02:15:55 UTC
FEDORA-2020-fb18e81c97 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-fb18e81c97`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-fb18e81c97

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Daniel 2020-11-13 07:57:45 UTC
I got the following error while running `sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-903bc82607` on Fedora 32.

Error: Transaction test error:
  file /usr/bin/pdfclose from install of texlive-xpdfopen-7:20200327-17.fc32.x86_64 conflicts with file from package texlive-pdftools-7:20190410-12.fc32.x86_64
  file /usr/bin/pdfopen from install of texlive-xpdfopen-7:20200327-17.fc32.x86_64 conflicts with file from package texlive-pdftools-7:20190410-12.fc32.x86_64
  file /usr/bin/texconfig from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-texconfig-7:20190410-12.fc32.noarch
  file /usr/bin/allcm from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-tetex-7:20190410-12.fc32.noarch
  file /usr/bin/allneeded from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-tetex-7:20190410-12.fc32.noarch
  file /usr/bin/dvi2fax from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-tetex-7:20190410-12.fc32.noarch
  file /usr/bin/dvired from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-tetex-7:20190410-12.fc32.noarch
  file /usr/bin/kpsetool from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-tetex-7:20190410-12.fc32.noarch
  file /usr/bin/kpsewhere from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-tetex-7:20190410-12.fc32.noarch
  file /usr/bin/texconfig-dialog from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-tetex-7:20190410-12.fc32.noarch
  file /usr/bin/texconfig-sys from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-tetex-7:20190410-12.fc32.noarch
  file /usr/bin/texlinks from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-tetex-7:20190410-12.fc32.noarch
  file /usr/bin/e2pall from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-pdftools-7:20190410-12.fc32.x86_64
  file /usr/bin/ps2frag from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-pstools-7:20190410-12.fc32.x86_64
  file /usr/bin/pslatex from install of texlive-texlive-scripts-extra-7:20200327-17.fc32.noarch conflicts with file from package texlive-pstools-7:20190410-12.fc32.x86_64
  file /usr/bin/pdftosrc from install of texlive-pdftosrc-7:20200327-17.fc32.x86_64 conflicts with file from package texlive-pdftools-7:20190410-12.fc32.x86_64
  file /usr/share/man/man1/pdftosrc.1.gz from install of texlive-pdftosrc-7:20200327-17.fc32.x86_64 conflicts with file from package texlive-pdftools-7:20190410-12.fc32.x86_64
  file /usr/bin/pdfatfi from install of texlive-attachfile2-7:20200327-17.fc32.noarch conflicts with file from package texlive-pdftools-7:20190410-12.fc32.x86_64
  file /usr/bin/bbox from install of texlive-ps2eps-7:20200327-17.fc32.x86_64 conflicts with file from package texlive-pstools-7:20190410-12.fc32.x86_64

Comment 16 Kai Hambrecht 2020-11-13 19:00:30 UTC
Btw, looks like this currently also blocks upgrades from F31 to F32 via dnf system-upgrade:

# dnf   system-upgrade  --releasever 32 download 

[...]

Error: Transaction test error:
  file /usr/bin/texconfig conflicts between attempted installs of texlive-texconfig-7:20190410-12.fc32.noarch and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /etc/texlive/web2c/updmap.cfg conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/bin/allcm conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /usr/bin/allneeded conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /usr/bin/dvi2fax conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /usr/bin/dvired conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /usr/bin/kpsetool conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /usr/bin/kpsewhere conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /usr/bin/texconfig-dialog conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /usr/bin/texconfig-sys conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /usr/bin/texlinks conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /usr/share/man/man1/fmtutil.1.gz conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/man/man1/updmap.1.gz conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/fmtutil-user.sh conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/fmtutil.pl conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/updmap-user.sh conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/updmap.pl conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/bin/e2pall conflicts between attempted installs of texlive-pdftools-7:20190410-12.fc32.x86_64 and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /usr/bin/pdfatfi conflicts between attempted installs of texlive-pdftools-7:20190410-12.fc32.x86_64 and texlive-attachfile2-7:20200327-16.fc32.noarch
  file /usr/bin/pdfclose conflicts between attempted installs of texlive-pdftools-7:20190410-12.fc32.x86_64 and texlive-xpdfopen-7:20200327-16.fc32.x86_64
  file /usr/bin/pdfopen conflicts between attempted installs of texlive-pdftools-7:20190410-12.fc32.x86_64 and texlive-xpdfopen-7:20200327-16.fc32.x86_64
  file /usr/bin/pdftosrc conflicts between attempted installs of texlive-pdftools-7:20190410-12.fc32.x86_64 and texlive-pdftosrc-7:20200327-16.fc32.x86_64
  file /usr/share/man/man1/pdftosrc.1.gz conflicts between attempted installs of texlive-pdftools-7:20190410-12.fc32.x86_64 and texlive-pdftosrc-7:20200327-16.fc32.x86_64
  file /usr/bin/bbox conflicts between attempted installs of texlive-pstools-7:20190410-12.fc32.x86_64 and texlive-ps2eps-7:20200327-16.fc32.x86_64
  file /usr/bin/ps2frag conflicts between attempted installs of texlive-pstools-7:20190410-12.fc32.x86_64 and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch
  file /usr/bin/pslatex conflicts between attempted installs of texlive-pstools-7:20190410-12.fc32.x86_64 and texlive-texlive-scripts-extra-7:20200327-16.fc32.noarch

Comment 17 Fedora Update System 2020-11-17 01:35:30 UTC
FEDORA-2020-fb18e81c97 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Robert Smalley 2020-11-20 09:52:09 UTC
Attempting to install R on Fedora 32:

> sudo dnf install R

results in the following error:

Error: Transaction test error:
  file /etc/texlive/web2c/updmap.cfg conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/man/man1/fmtutil.1.gz conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/man/man1/updmap.1.gz conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/fmtutil-user.sh conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/fmtutil.pl conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/updmap-user.sh conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch
  file /usr/share/texlive/texmf-dist/scripts/texlive/updmap.pl conflicts between attempted installs of texlive-tetex-7:20190410-12.fc32.noarch and texlive-texlive-scripts-7:20200327-16.fc32.noarch

When will the F33 stable repo fix be available to F32?

Comment 19 Fedora Update System 2020-11-21 01:44:56 UTC
FEDORA-2020-903bc82607 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 20 Martin Smith 2020-11-21 09:45:06 UTC
This seems to be an improvement but I'm still seeing some issues on F32:

Error: Transaction test error:
  file /usr/bin/pdfclose from install of texlive-xpdfopen-7:20200327-18.fc32.x86_64 conflicts with file from package texlive-pdftools-7:20190410-12.fc32.x86_64
  file /usr/bin/pdfopen from install of texlive-xpdfopen-7:20200327-18.fc32.x86_64 conflicts with file from package texlive-pdftools-7:20190410-12.fc32.x86_64
  file /usr/bin/pdfatfi from install of texlive-attachfile2-7:20200327-18.fc32.noarch conflicts with file from package texlive-pdftools-7:20190410-12.fc32.x86_64
  file /usr/bin/bbox from install of texlive-ps2eps-7:20200327-18.fc32.x86_64 conflicts with file from package texlive-pstools-7:20190410-12.fc32.x86_64

Comment 21 Martin Smith 2020-11-22 07:57:52 UTC
Those conflicting packages seemed to be fairly old. I removed the following:

texlive-pdftools 
texlive-pstools 
texlive-collection-binextra 
texlive-collection-fontutils 
texlive-scheme-tetex

And it seems to be OK now.


Note You need to log in before you can comment on or make changes to this bug.