Bug 189625 - Unable to change package install if not connected to the WEB
Unable to change package install if not connected to the WEB
Status: CLOSED RAWHIDE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stuart Ellis
Paul W. Frields
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 14:45 EDT by Bruce Butterfield
Modified: 2007-04-18 13:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-01 18:11:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Copy of WEB page which provides solutions for using pirut with local files (6.33 KB, text/html)
2006-04-21 14:45 EDT, Bruce Butterfield
no flags Details

  None (edit)
Description Bruce Butterfield 2006-04-21 14:45:01 EDT
Description of problem:

The current base installation process puts "pirut" as the application used 
to "Add/Change Programs", which is based on "yum". On old versions of RedHat, 
or on most distros, when you install from CDs you are allowed later to add or 
remove packages which are on the CDs. As currently configured, "yum" expects to 
go to the Internet to obtain a list of available packages to install, and to 
obtain them from the internet. 

If an installation is done on a computer which is not connected to the 
internet, and "pirut" is activated from the applications menu, it starts up and 
then immediately dies, because it cannot locate a list of packages. "pirut" 
indicates that the was an error, but does not provide any way of discovering 
what the problem was.

Until "yum" and "pirut" are configured to allow changing the set of installed 
packages from CD/DVD, some documentation is needed to help users access the 
applications on the CDs.


Version-Release number of selected component (if applicable): Fedora Core 5


How reproducible: 100%


Steps to Reproduce:
1. Do a basic install of Fedora Core 5 on a computer which is not connected to 
a network or the internet, using CDs
2. Attempt to use the application (pirut) to change which packages are installed
3. 
  
Actual results:
   o  pirut died indicating it could not find a package list. No reason given

Expected results:
   o  Expected to be able to install more packages from the install CDs


Additional info:

As new user (at least new to Fedora), this problem meant that I was unable to 
change the installed packages, or know why I could not do so. Since there were 
no other obvious way to install packages, I was stuck.

I later found a WEB site which told how to copy the install RPMs to a directory 
on the hard drive, fire up "yum" to get a list of packages, and then hand 
modify several of "yum"s configuration files to get the the packages locally. 
While this is not what a newbee would want to do, it at least did allow me to 
access the full package list so that I could evaluate Fedora. My thought is 
that this information should be a part of the install, or at least describe the 
issues in the install process and link to sites which provide solutions.

Since I did not copy the original site reference, I am including the site text 
(which mostly works).
Comment 1 Bruce Butterfield 2006-04-21 14:45:02 EDT
Created attachment 128096 [details]
Copy of WEB page which provides solutions for using pirut with local files
Comment 2 Stuart Ellis 2006-04-30 10:13:45 EDT
OK, thanks. I've amended the sections of the IG that relate to pup and pirut, to
note that these (currently) require network connectivity.

The first option in that page that you've attached is similar to the process in
the mirror tutorial, although it uses filesystem access rather than going via a
HTTP server.

Mirror Tutorial:

http://fedora.redhat.com/docs/mirror/

Configuring installation sources is out of scope for the IG, but it may be
viable to add something to the mirror tutorial...

If you file a bug on the mirror-tutorial WRT documenting filesystem access we
can discuss it with the maintainer of that document. 
Comment 3 Bruce Butterfield 2006-05-01 17:33:42 EDT
I was not trying to create a "mirror" on my system. I was using that as a 
desperation method of making Fedora Core usable. The problem I originally faced 
was that after an initial CD installation, there was no way to change what was 
installed on my system. I could not add or delete anything.

Since this will "hopefully" be fixed by a code change in "yum" in the future, I 
will have to revert back to SuSE until it gets fixed. 
Comment 4 Paul W. Frields 2006-05-01 18:09:07 EDT
All you need to do in order to add/remove programs is to copy CD contents
(packages) to your hard disk and set up a local repository.  Then you simply
disable the network-based repositories and use your own local one instead.  This
is not a yum problem; it's a local configuration problem.

Stuart, this would probably be useful info for either the IG or the yum
tutorial.  This problem has come up numerous times on IRC and in the forums, and
would be worth addressing wherever you think is the right place for it.  Do you
agree?
Comment 5 Paul W. Frields 2006-05-01 18:11:47 EDT
Oops, I didn't mean to reopen this, was leaving that up to Stuart.
Comment 6 Stuart Ellis 2006-05-02 17:45:25 EDT
I agree that it's useful, but I don't think it really fits in either document -
anaconda and yum are client applications that can both use a common set of
repositories or mirrors built by the user.

Building a local repository has a lot of steps in common with mirrors, so I
shelved the material that I wrote for this procedure in favour of the mirror
tutorial. The source for that is in FDP document format:

http://www.elsn.org/install-servers/installation-servers-en.xml

I think that problem is partly one of terminology - "mirrors", "deployment
servers", network "application repositories", and local package stores can be
all be the same thing with Fedora, but that's not necessarily obvious. I'm not
sure how we can address that.

Note You need to log in before you can comment on or make changes to this bug.