Bug 1896383 - botan fails to build with Python 3.10: SystemError: PY_SSIZE_T_CLEAN macro must be defined for '#' formats
Summary: botan fails to build with Python 3.10: SystemError: PY_SSIZE_T_CLEAN macro m...
Keywords:
Status: CLOSED DUPLICATE of bug 1896382
Alias: None
Product: Fedora
Classification: Fedora
Component: botan
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Moschny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-10 12:37 UTC by Tomáš Hrnčiar
Modified: 2020-11-16 10:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-16 10:44:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-10 12:37:19 UTC
botan fails to build with Python 3.10.0a2.

src/wrap/python/core.cpp:192:59:   required from here
/usr/include/boost/python/object/make_instance.hpp:50:13: error: lvalue required as left operand of assignment
   50 |             Py_SIZE(instance) = offsetof(instance_t, storage);
      |             ^~~~~~~

https://docs.python.org/3.10/whatsnew/3.10.html#id2

The PY_SSIZE_T_CLEAN macro must now be defined to use PyArg_ParseTuple() and Py_BuildValue() formats which use #: es#, et#, s#, u#, y#, z#, U# and Z#. See Parsing arguments and building values and the PEP 353.
https://docs.python.org/3.10/c-api/arg.html#arg-parsinghttps://www.python.org/dev/peps/pep-0353https://bugs.python.org/issue40943

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01756966-botan/

For all our attempts to build botan with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/botan/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-11-16 10:44:16 UTC

*** This bug has been marked as a duplicate of bug 1896382 ***


Note You need to log in before you can comment on or make changes to this bug.