Bug 1896485 - knmstate metrics port is colliding with ovirt-csi-driver-operator [NEEDINFO]
Summary: knmstate metrics port is colliding with ovirt-csi-driver-operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: Networking
Version: 2.4.3
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 2.5.2
Assignee: Quique Llorente
QA Contact: Ofir Nash
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-10 17:02 UTC by Petr Horáček
Modified: 2020-12-16 00:17 UTC (History)
4 users (show)

Fixed In Version: cluster-network-addons-operator-container-v2.5.2-3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-16 00:16:58 UTC
Target Upstream Version:
danken: needinfo? (ellorent)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github nmstate kubernetes-nmstate pull 624 0 None closed Disable metrics default behaviour 2020-12-13 09:46:50 UTC
Red Hat Bugzilla 1896320 0 medium CLOSED ovirt-csi-driver-operator pod crashes upon OCP upgrade from 4.5 to 4.6 on RHV platform 2021-02-25 14:46:26 UTC
Red Hat Product Errata RHEA-2020:5560 0 None None None 2020-12-16 00:17:06 UTC

Description Petr Horáček 2020-11-10 17:02:39 UTC
Description of problem:
knmstate listens on port 8080 on cluster nodes. The port is meant for metrics, but we never use it. It just happens to be enabled by default. Due to this, we collide with another cluster component Bug 1896320.


Version-Release number of selected component (if applicable):
CNV 2.4, 2.5
OCP 4.6
ovirt provider


How reproducible:
Always


Steps to Reproduce:
1. Deploy CNV on OCP on oVirt

Actual results:
https://bugzilla.redhat.com/show_bug.cgi?id=1896320


Expected results:
Smooth upgrade.

Additional info:

Comment 1 Dan Kenigsberg 2020-11-11 09:27:17 UTC
Can we somehow let k8s allocate a free nodePort instead of hard-coding 8080?

Comment 2 Yossi Segev 2020-12-13 15:55:46 UTC
Verified on:
$ oc version
Client Version: 4.6.0-202010271321.p0-ffd6836
Server Version: 4.6.7
Kubernetes Version: v1.19.0+1348ff8

$ oc get csv -n openshift-cnv
NAME                                      DISPLAY                    VERSION   REPLACES                                  PHASE
kubevirt-hyperconverged-operator.v2.5.2   OpenShift Virtualization   2.5.2     kubevirt-hyperconverged-operator.v2.5.1   Succeeded

registry.redhat.io/container-native-virtualization/kubernetes-nmstate-handler-rhel8@sha256:b323cf93cac96d4a4a840b84232be4a1fa90121506c8f28e5336a49f4b78030f


1. Shell to one of the nmstate-handler pods in the cluster:
$ oc exec -n openshift-cnv -it nmstate-handler-4x4nl -- bash

2. Verify no one is listening on port 8080:
[root@test-252-lg4gx-worker-0-5w9v5 /]# ss -ap | grep -w 8080
[root@test-252-lg4gx-worker-0-5w9v5 /]#

Comment 8 errata-xmlrpc 2020-12-16 00:16:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Virtualization 2.5.2 Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:5560


Note You need to log in before you can comment on or make changes to this bug.