Bug 189653 - booting up does not allow keybooad entry at login prompt
booting up does not allow keybooad entry at login prompt
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-keyboard (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 22:09 EDT by Chris Allen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 12:25:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Allen 2006-04-21 22:09:16 EDT
Description of problem:
When I start PC, the login promt frequently does not allow ketboard entry.
This has happen frequently since I upgreaded to FC5.
It never happened in Red Hat or FC4.

To get araound this, I use the mouse to select Restart
and do a complete shut down and restart 
until the login prompt decides to accept keyboard entry.
This may take 3 or 4 attempts.

Every time the boot process begins 
I can hear the system test to see if the test access to a floopy drive.
At the same time it test acces to and finds the keybord. I know this beacuse I
ALWAYS see the Num Lock led shine for about 5 seconds.  This occurs after the
FC5 has taken contol of the boot process.

Howaver when the login screen finally presents itself, it won't accept any
keyboard entry.

Usually the 3rd or 4th reboot will allow keyboard entry and I have no trouble
after that.

How reproducible:
Occurs on most attemps to start up.


Steps to Reproduce:
1. start up
  
Additional info:
I use a DELL work station (originall had RH 3 pre-installed)
with a dell USB keyboard.

This is clearly not a cabling issue beacuse ALWAY I see the Num Lock led
flashing during the early stages of startup.
Comment 1 Mike A. Harris 2006-04-24 20:24:55 EDT
In order to diagnose a problem of this nature, we require a reproduceable
test case which can be duplicated in our lab.  No other user has reported
a problem of this nature, so there is nothing else to go on other than what
is present in this bug report currently, and the problem is not occuring on
any systems I've seen.

It is very unlikely that this is an X server keyboard driver bug, so the
problem will need to be narrowed down to the specific component that is
responsible on a system to which the problem can be reliably reproduced on.

Are you using any 3rd party video drivers, kernel modules or anything else?

Are you using a KVM switch?

Comment 2 Chris Allen 2006-04-25 00:14:58 EDT
I am not using ANY 3rd party software. Everything loaded on this system is from
a RH disk.

I bought the system (low end DELL Work station) in December 2004 with RH WS3 pre
installed.  Switched to FC4 in August 2005 (disk came from Everything Linux,
Sydney).  In late Marche at Sydney Linux Conference I collected a new disk for
FC5 at the Redhat Stand.  I used this to upgrade to FC5.

I experienced this problem with the very first restart after upgrading.  It has
happened intermitantly since then. (no trouble today, yet).

"Are you using any 3rd party video drivers, kernel modules or anything else?"  NO.
"Are you using a KVM switch?"  What does "KVM switch" mean.  The only "extra"
hard ware I ues is an ADSL router, printer and USB memeory stick (nearly always
pluged in).

I don't know if this is relavant, but I can't mount a floppy disk either.  I was
going to raise this as another bug report.

"we require a reproduceable test case which can be duplicated in our lab"
Not sure what I can give you.  I power on and sometimes the login prompt accepts
the keyboard but more often does not.  If it does not I select "Restart" with
the mouse until I eventually get in (mouse always works).  I have not tweaked
any system files (don't know enough to try).

"to duplicate in our lab", you might have to bring the lab here to see for yourself.
Comment 3 Chris Allen 2006-05-10 22:57:28 EDT
I enentually gor around this problem by using a cheap PS2 keyboard.
Comment 4 Mike A. Harris 2006-06-27 12:25:38 EDT
This is probably a kernel driver related problem, or a bug in your system
BIOS, or a configuration option in your CMOS settings which is misconfigured
for running under Linux.

At any rate, USB keyboards are the norm nowadays, and there have not been
any other reports of this problem.  We are unable to reproduce this on
test systems.

Closing as "WORKSFORME"

Note You need to log in before you can comment on or make changes to this bug.