Red Hat Bugzilla – 1896595 – [RHEL-8.4.0][aarch64] kdumpctl[1917]: Cannot determine the file type of /boot/vmlinuz-4.18.0-247.el8.aarch64 after system boot up.
Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
In aws r6g.metal instance, kdump service failed to start with RHEL-8.4.0-20201110.n.1 installed.
[root@ip-10-116-2-29 ec2-user]# journalctl -u kdump
-- Logs begin at Wed 2020-11-11 01:43:41 UTC, end at Wed 2020-11-11 02:00:10 UTC. --
Nov 11 01:43:47 ip-10-116-2-29.us-west-2.compute.internal systemd[1]: Starting Crash recovery kernel arming...
Nov 11 01:43:48 ip-10-116-2-29.us-west-2.compute.internal kdumpctl[1917]: Cannot determine the file type of /boot/vmlinuz-4.18.0-247.el8.aarch64
Nov 11 01:43:48 ip-10-116-2-29.us-west-2.compute.internal kdumpctl[1917]: kexec: failed to load kdump kernel
Nov 11 01:43:48 ip-10-116-2-29.us-west-2.compute.internal kdumpctl[1917]: Starting kdump: [FAILED]
Nov 11 01:43:48 ip-10-116-2-29.us-west-2.compute.internal systemd[1]: kdump.service: Main process exited, code=exited, status=1/FAILURE
Nov 11 01:43:48 ip-10-116-2-29.us-west-2.compute.internal systemd[1]: kdump.service: Failed with result 'exit-code'.
Nov 11 01:43:48 ip-10-116-2-29.us-west-2.compute.internal systemd[1]: Failed to start Crash recovery kernel arming.
# rpm -q kexec-tools
kexec-tools-2.0.20-36.el8.aarch64
# lscpu
Architecture: aarch64
Byte Order: Little Endian
CPU(s): 64
On-line CPU(s) list: 0-63
Thread(s) per core: 1
Core(s) per socket: 64
Socket(s): 1
NUMA node(s): 1
Vendor ID: ARM
Model: 1
Stepping: r3p1
BogoMIPS: 243.75
L1d cache: 64K
L1i cache: 64K
L2 cache: 1024K
L3 cache: 32768K
NUMA node0 CPU(s): 0-63
Flags: fp asimd evtstrm aes pmull sha1 sha2 crc32 atomics fphp asimdhp cpuid asimdrdm lrcpc dcpop asimddp ssbs
Version-Release number of selected components (if applicable):
RHEL Version:
RHEL-8.4(4.18.0-247.el8.aarch64)
How reproducible:
100%
Steps to Reproduce:
1. Start a RHEL-8.4 aws r6g.metal instance
2. Check kdump service status
Actual results:
It is failed to start
Expected results:
In running status
Additional info:
- No such problem in x86_64