Bug 1896783 - dnfdaemon fails to build with Python 3.10: /usr/bin/python3.1: No such file or directory
Summary: dnfdaemon fails to build with Python 3.10: /usr/bin/python3.1: No such file o...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdaemon
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1968797 (view as bug list)
Depends On:
Blocks: PYTHON3.10 F35FTBFS F35FailsToInstall 1968797 1968798
TreeView+ depends on / blocked
 
Reported: 2020-11-11 14:24 UTC by Tomáš Hrnčiar
Modified: 2021-06-10 15:11 UTC (History)
6 users (show)

Fixed In Version: dnfdaemon-0.3.20-6.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-10 15:11:20 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-11 14:24:35 UTC
dnfdaemon fails to build with Python 3.10.0a2.

/usr/lib/rpm/redhat/brp-python-bytecompile: line 45: /usr/bin/python3.1: No such file or directory
/usr/lib/rpm/redhat/brp-python-bytecompile: line 50: [: : integer expression expected
/usr/lib/rpm/redhat/brp-python-bytecompile: line 65: [: : integer expression expected
/usr/lib/rpm/redhat/brp-python-bytecompile: line 82: /usr/bin/python3.1: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.62nKTt (%install)

Seems like there is some bug in makefile that detects wrong Python version - 3.1 instead of 3.10.

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01760237-dnfdaemon/

For all our attempts to build dnfdaemon with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/dnfdaemon/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-11-11 14:42:39 UTC
$ rg -F 'sys.version'
python/dnfdaemon/Makefile
4:PYVER3 := $(shell $(PYTHON3) -c 'import sys; print("%.3s" %(sys.version))')

python/dnfdaemon/client/Makefile
4:PYVER3 := $(shell $(PYTHON3) -c 'import sys; print("%.3s" %(sys.version))')

python/dnfdaemon/server/Makefile
4:PYVER3 := $(shell $(PYTHON3) -c 'import sys; print("%.3s" %(sys.version))')

Makefile
12:PYVER3 := $(shell python3 -c 'import sys; print("%.3s" %(sys.version))')


$ python3.10 -c 'import sys; print("%.3s" %(sys.version))'
3.1

Comment 2 Miro Hrončok 2021-06-04 20:12:45 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:57:45 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 10:27:47 UTC
This blocks the rebuild of dnfdragora and hence some media fails to compose: https://pagure.io/releng/failed-composes/issue/2553#comment-736713

Comment 5 Miro Hrončok 2021-06-08 11:14:27 UTC
*** Bug 1968797 has been marked as a duplicate of this bug. ***

Comment 6 Carl George 🤠 2021-06-10 15:11:20 UTC
I've submitted a fix upstream [0] and applied it as a patch to the package to get it to build [1].

[0] https://github.com/manatools/dnfdaemon/pull/48
[1] https://bodhi.fedoraproject.org/updates/FEDORA-2021-98d3ad3674


Note You need to log in before you can comment on or make changes to this bug.