Bug 1896875 - fapolicyd breaks system upgrade, leaving system in dead state - complete fix
Summary: fapolicyd breaks system upgrade, leaving system in dead state - complete fix
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: fapolicyd
Version: 8.3
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: 8.0
Assignee: Radovan Sroka
QA Contact: Dalibor Pospíšil
Mirek Jahoda
URL:
Whiteboard:
: 1895467 1897323 (view as bug list)
Depends On: 1895467
Blocks: 1895513 1895514 1895515 1897090 1897091 1897092
TreeView+ depends on / blocked
 
Reported: 2020-11-11 18:09 UTC by Lukas Vrabec
Modified: 2021-06-14 13:35 UTC (History)
34 users (show)

Fixed In Version: fapolicyd-1.0.2-5.el8
Doc Type: Bug Fix
Doc Text:
.`fapolicyd` no longer prevents RHEL updates When an update replaces the binary of a running application, the kernel modifies the application binary path in memory by appending the `(deleted)` suffix. Previously, the `fapolicyd` file access policy daemon treated such applications as untrusted. As a consequence, `fapolicyd` prevented these applications from opening and executing any other files. With this update, `fapolicyd` ignores the suffix in the binary path so the binary can match the trust database. As a result, `fapolicyd` enforces the rules correctly and the update process can finish.
Clone Of: 1895467
: 1897090 1897091 1897092 (view as bug list)
Environment:
Last Closed: 2021-05-18 16:22:41 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 5542661 0 None None None 2020-11-11 19:37:55 UTC
Red Hat Knowledge Base (Solution) 5573841 0 None None None 2020-11-12 20:40:35 UTC

Comment 3 Lukas Vrabec 2020-11-11 19:37:56 UTC
*** Bug 1895467 has been marked as a duplicate of this bug. ***

Comment 7 Chris Williams 2020-11-12 20:40:35 UTC
*** Bug 1897323 has been marked as a duplicate of this bug. ***

Comment 37 Amit Kumar Das 2021-04-27 06:44:30 UTC
Lukas - Thanks for confirming on RHEL-8.4 GA. Can you confirm that fix will be included in RHEL-8.3.Z rollout?

Comment 40 errata-xmlrpc 2021-05-18 16:22:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (fapolicyd bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2021:1952


Note You need to log in before you can comment on or make changes to this bug.