Bug 1896929 - systemd complains about Unit configured to use KillMode=none
Summary: systemd complains about Unit configured to use KillMode=none
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: 33
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1889923 1931682 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-11 21:48 UTC by Orion Poplawski
Modified: 2021-03-28 00:15 UTC (History)
9 users (show)

Fixed In Version: plymouth-0.9.5-1.20210323git8a3c9bb.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-28 00:15:23 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
freedesktop.org Gitlab plymouth plymouth issues 123 0 None None None 2020-11-20 16:10:27 UTC

Description Orion Poplawski 2020-11-11 21:48:14 UTC
Description of problem:

/usr/lib/systemd/system/plymouth-start.service:15: Unit configured to use KillMode=none. This is unsafe, as it disables systemd's process lifecycle management for the service. Please update your service to use a safer KillMode=, such as 'mixed' or 'control-group'. Support for KillMode=none is deprecated and will eventually be removed

Version-Release number of selected component (if applicable):
plymouth-0.9.4-16.20200325gite31c81f.fc33.x86_64
systemd-246.6-3.fc33.x86_64

Comment 1 John Dodson 2021-01-28 12:34:44 UTC
So should it be 'mixed' or 'control-group' what are the effects of each for plymouth & systemd?

Comment 2 Hans de Goede 2021-02-23 21:34:23 UTC
*** Bug 1931682 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2021-03-23 13:35:19 UTC
FEDORA-2021-ebde0e7e8a has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ebde0e7e8a

Comment 4 Fedora Update System 2021-03-24 02:44:32 UTC
FEDORA-2021-ebde0e7e8a has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-ebde0e7e8a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-ebde0e7e8a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Hans de Goede 2021-03-25 11:39:01 UTC
*** Bug 1889923 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2021-03-28 00:15:23 UTC
FEDORA-2021-ebde0e7e8a has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.