Bug 189694 - Cannot boot FC5 on VIA C3 machine
Summary: Cannot boot FC5 on VIA C3 machine
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 5
Hardware: other
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-23 10:14 UTC by Simon Roberts
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-23 15:40:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Simon Roberts 2006-04-23 10:14:42 UTC
Description of problem:
Unable to boot existing FC5 installation with VIA C3 800A system.  Operating
system was previously installed on a different machine, everything works fine
there. i586 kernel is installed, and hard-drive is moved to C3 machine
(embedded-ish media PC).  Grub loads, select kernel, and it fails during booting at:

  Setting up new root fs
  no fstab.sys, mounting internal defaults
  switching to new root and running init
  unmounting old /dev
  unmounting old /proc
  unmounting old /sys

At this point, nothing more happens, though system responds to
control-alt-delete etc. The same machine worked fine with FC2 (or so), perhaps
using c3boot.iso IIRC


Version-Release number of selected component (if applicable):
Same results with 
kernel-2.6.16-1.2096_FC5 (i586)
kernel-2.6.15-1.2054_FC5 (i586)
kernel-smp-2.6.16-1.2096_FC5  (i586)

How reproducible:
Every time

Steps to Reproduce:
1. Power on machine, select any FC5 i586 kernel
2. Crash/hang as described above
3.
  

Additional info:
Perhaps related to bug 120685
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=120685
syslinux or kernel related?

Comment 1 Simon Roberts 2006-04-23 13:30:20 UTC
Looking at the messages as the kernel boots up, it seems that the drives (etc)
are all detected fine. I even made a new initrd that included a bunch of extra
modules (libata, sd_mod, etc), but that didn't change anything.

Interestingly, the system boots off the FC5 install disk (linux rescue) fine,
detects the filesystem etc, but when I attempt to "chroot /mnt/sysimage/" it
gives me an "illegal instruction" error.  Is something in that binary using
i686-only instructions?  Could that also be the reason that switchroot is failing?


Comment 2 Simon Roberts 2006-04-23 15:40:03 UTC
Okay, I figured it out (my bad).  Replaced glibc-686 with 386, and things
started working properly. Thanks.


Note You need to log in before you can comment on or make changes to this bug.