Bug 189706 - Nautilus hangs reading large anim gif
Nautilus hangs reading large anim gif
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-23 10:55 EDT by Radek Vokal
Modified: 2015-03-03 17:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:50:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace call summary (1.66 KB, text/plain)
2006-10-16 16:43 EDT, Dani Perez
no flags Details
The full strace log. (1.35 MB, application/x-gzip)
2006-10-16 16:48 EDT, Dani Perez
no flags Details

  None (edit)
Description Radek Vokal 2006-04-23 10:55:03 EDT
Description of problem:
After update to 2.14.1 I can't access my home folder. Nautilus shows number of
files in folder but also hangs not showing any file or folder from my home.
Happens always, I've updated to rawhide nautilus-2.14.1-2 and have the same problem.

Version-Release number of selected component (if applicable):
nautilus-2.14.1-2 (1.fc5.1)


How reproducible:
Probably some strange crappy files are placed in my home folder, but it used to
work. I'll try to downgrade and let you know the results

Steps to Reproduce:
1.open home folder
2.
3.
  
Actual results:
eats 100% CPU

Expected results:
works

Additional info:
Can I somehow get some gdb trace of what's happening there? I've tried to attach
to nautilus pid but don't know how to get some useful info. 

Also what is watching nautilus and restarts it every time I kill it? It opens my
home folder so I end up in dead loop.
Comment 1 Radek Vokal 2006-05-13 04:50:13 EDT
removing nautilus settings fixed the issue, but I lost my cute icons etc... 
Comment 2 Alexander Larsson 2006-09-04 12:37:48 EDT
If you see this again, reopen with an strace and a backtrace.
Comment 3 Dani Perez 2006-10-15 14:49:14 EDT
I'm having the same problem. Nautilus eats as much memory as he can. I upgraded
from Fedora Core 5 (updated) to Fedora Core 6 Test 3 (also updated to the last
packages in repository), thinking it would solve the problem, but no way. 

I cannot say what version of Nautilus I was running in Fedora Core 5, but I'd
say it was 2.14.0. In Fedora Core 6 Test 3, I'm running Nautilus version 2.16.0.

Nautilus is being loaded from the very beginning (when you log in a gnome
session) and after it consumes a worthy amount of memory (slowing the system),
it's killed, but it's being reloaded due to the "restart" policy of nautilus
specified at /usr/share/gnome/default.session. And this way forever.

It's quite frustating because I'm still suffering this bug after a fresh install.

The only way I found to circumbent this issue was to create
$HOME/.gnome2/session custom file, excluding nautilus in it (this can be also
achieved with gnome-session-properties). Of course, this tip prevents from using
nautilus...
Comment 4 Alexander Larsson 2006-10-16 07:07:13 EDT
Can you get an strace and a backtrace from the looping nautilus process?
Comment 5 Dani Perez 2006-10-16 15:55:46 EDT
I've found that that problem was caused by one or more files (no more than 15)
in my Desktop folder. Moving all these files into a new folder located at
Desktop/ worked for me.

I'll try to provide the strace/backtrace or isolate the "guilty" file/s.
Comment 6 Dani Perez 2006-10-16 16:43:00 EDT
Created attachment 138622 [details]
Strace call summary
Comment 7 Dani Perez 2006-10-16 16:48:45 EDT
Created attachment 138623 [details]
The full strace log.

The previously commented dir which has been created inside Desktop directoy is
called "all_deskptop" (typo included). This trace is from the process of
opening that folder.
Comment 8 Dani Perez 2006-10-18 04:17:53 EDT
I succeeded to isolate the "guilty" file. It's a 1,1 MB file with no extension,
which "file" command identifies as a GIF. I'd say that it's a file I created
with gnome Istanbul screen capture software. I've tried to open it with The GIMP
and it seems to loop infinitely (or too long at least) while loading.

I'd say that Nautilus, like The GIMP, hangs while trying to render the thumbnail
of that file...

I could send that file if it can be assured its confidentiality somehow, since I
don't know what's inside (probably just some tests with Istanbul software).

I had some problems to get the backtrace, since Nautilus seems to stop running
as soon as I attach gdb, or maybe it takes too much time... I cannot say.
Comment 9 Alexander Larsson 2006-10-19 04:48:08 EDT
I wonder why its hanging. Nautilus does thumbnailing in a thread, so it
shouldn't hang the UI, only not do any other thumbnails for a while.
Comment 10 Alexander Larsson 2006-10-19 04:50:23 EDT
Looking at the end of the strace it doesn't look hanged. It just sits in poll()
(which is likely the mainloop). The thumbnailing i/o is not visible at all
because the strace only shows the main thread.
Comment 11 Bug Zapper 2008-04-03 22:44:31 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 12 Bug Zapper 2008-05-06 11:50:08 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.