Bug 1897076 - kig fails to build with Python 3.10: Py_SIZE= needs to be replaced with Py_SET_SIZE
Summary: kig fails to build with Python 3.10: Py_SIZE= needs to be replaced with Py_SE...
Keywords:
Status: CLOSED DUPLICATE of bug 1896382
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jonathan Wakely
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2020-11-12 09:03 UTC by Tomáš Hrnčiar
Modified: 2020-11-12 11:46 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-12 11:46:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2020-11-12 09:03:02 UTC
kig fails to build with Python 3.10.0a2.

/usr/include/python3.10/object.h:134:29: error: lvalue required as left operand of assignment
  134 | #define Py_SIZE(ob) _Py_SIZE(_PyVarObject_CAST_CONST(ob))
      |                     ~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~

https://docs.python.org/3.10/whatsnew/changelog.html#id11

bpo-39573: Convert Py_REFCNT() and Py_SIZE() macros to static inline functions. They cannot be used as l-value anymore: use Py_SET_REFCNT() and Py_SET_SIZE() to set an object reference count and size. This change is backward incompatible on purpose, to prepare the C API for an opaque PyObject structure.
https://bugs.python.org/issue39573

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01757104-kig/

For all our attempts to build kig with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/kig/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Kevin Kofler 2020-11-12 11:46:32 UTC
Kig uses Boost::Python, not the Python libraries directly. The errors all come from inline code in Boost::Python headers. Kig does not call the offending macro directly, so there is nothing to fix in Kig.

*** This bug has been marked as a duplicate of bug 1896382 ***


Note You need to log in before you can comment on or make changes to this bug.